1166: 判断升序

题目

Description

实现public static boolean isSorted(int[] table)

判断整数数组元素是否已经按升序排序。

Input

一列数,需要判断的数组元素。

Output

如果已经排序输出YES

如果没有排序输出NO

Sample Input

1
2
3
4
5
6
Sample Output

YES


代码块

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner cn = new Scanner(System.in);
        int[] n = new int[10001];
        int i =0;
        while(cn.hasNext()){
            n[i] =cn.nextInt();
            i++;
        }
        if(isSorted(n,i))//进行判断输出
            System.out.println("YES");
        else System.out.println("NO");
    }

    private static boolean isSorted(int[] n,int i) {
        for(int j =0 ;j<i-1;j++){
            if(n[j]>n[j+1]) return false;
        }
        return true;
    }
}
  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值