1289: 简单数据统计

题目

Description

输入若干个整数求出他们的最小值,最大值,平均值(保留三位有效数字)输入保证这些数都不超过1000的正整数

Input

输入若干个整数

Output

求出他们的最小值,最大值,平均值(保留三位有效数字)

Sample Input

2 8 3 5 1 7 3 6
Sample Output

1 8 4.375


代码块

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner cn = new Scanner(System.in);
        int min = 1000;
        int max = 0;
        int sum = 0;
        int count =0;
        while(cn.hasNext()){
            int a = cn.nextInt();
            if(min>a) min = a;
            if(max<a) max = a;
            sum += a;
            count++;
        }
        System.out.print(min+" "+max+" ");
        System.out.printf("%.3f\n",1.0*sum/count);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值