1330: Five Cards

题目

Description

马克在玩一个游戏,他有5张卡片,每张卡片上会有一个数字。每个数字是一个正整数
马克可以丢弃一些卡片。他的目标是得到剩余卡片数字的最小和
允许马克丢弃两张或三张卡片(只能丢弃一次),并且丢弃的卡片的数字必须是相同的。当然,如果其中无相同数字的卡片,就不能丢弃卡片
给你5张卡片,你能找到在剩下卡片中的最小和吗?
Input

多组输入,每行输入包括5个数字t1,t2,t3,t4,和t5(1<=ti<=100),卡片上的的数字
Output

每组输出,输出剩下卡片上数字的最小和
Sample Input

7 3 7 3 20
7 9 3 1 8
10 10 10 10 10
Sample Output

26
28
20


代码块



import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner cn = new Scanner(System.in);
        while (cn.hasNext()) {
            int[] a = new int[5];
            int sum = 0;
            for (int i = 0; i < 5; i++) {
                a[i] = cn.nextInt();
                sum += a[i];
            }
            int max = 0;
            for (int i = 0; i < 4; i++) {
                if (a[i] == 0)
                    continue;
                int count = 0;
                for (int j = i + 1; j < 5; j++) {
                    if (a[j] == 0)
                        continue;
                    if (a[i] == a[j]) {
                        count++;
                        a[j] = 0;
                    }

                }
                if (count > 0 && count < 3) {
                    int z = (count + 1) * a[i];
                    if (z > max)
                        max = z;
                } else if (count >= 3) {
                    if (max < 3 * a[i])
                        max = 3 * a[i];
                }

            }
            System.out.println(sum - max);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,以下是一个简单的Clojure实现的德州扑克游戏: ```clojure (ns texas-holdem.core (:gen-class)) (def suits [:hearts :diamonds :clubs :spades]) (def ranks [:two :three :four :five :six :seven :eight :nine :ten :jack :queen :king :ace]) (defn shuffle-deck [] (shuffle (for [suit suits rank ranks] {:suit suit :rank rank}))) (defn deal [players deck] (loop [p players d deck hands []] (if (empty? p) hands (let [hand (take 2 d)] (recur (rest p) (drop 2 d) (conj hands (vec hand))))))) (defn flop [deck] (let [cards (take 3 deck) rest (drop 3 deck)] [cards rest])) (defn turn [deck] (let [card (first deck) rest (rest deck)] [card rest])) (defn river [deck] (let [card (first deck) rest (rest deck)] [card rest])) (defn best-hand [cards] (let [combinations (sequence 5 (subseq cards 0)) hands (map #(sort-by :rank %) (sequence 10 (combinations combinations))) flushes (filter #(= (count (distinct (map :suit %))) 1) hands) straights (filter #(= (count (distinct (map :rank %))) 5) hands) straight-flushes (filter #(and (= (count (distinct (map :suit %))) 1) (= (count (distinct (map :rank %))) 5)) hands) royal-flushes (filter #(= (count (distinct (map :rank %))) 5) straight-flushes)] (if (not-empty royal-flushes) {:hand :royal-flush :cards (first royal-flushes)} (if (not-empty straight-flushes) {:hand :straight-flush :cards (first straight-flushes)} (if (not-empty four-of-a-kinds) {:hand :four-of-a-kind :cards (first four-of-a-kinds)} (if (not-empty full-houses) {:hand :full-house :cards (first full-houses)} (if (not-empty flushes) {:hand :flush :cards (first flushes)} (if (not-empty straights) {:hand :straight :cards (first straights)} (if (not-empty three-of-a-kinds) {:hand :three-of-a-kind :cards (first three-of-a-kinds)} (if (not-empty two-pairs) {:hand :two-pair :cards (first two-pairs)} (if (not-empty pairs) {:hand :pair :cards (first pairs)} {:hand :high-card :cards (first hands)}))))))))))) (defn winner [hands] (let [best (apply max-key #(best-hand %) hands)] (filter #(= best (best-hand %)) hands))) (defn -main [] (let [players (list ["Player 1" :bankroll 100] ["Player 2" :bankroll 100]) deck (shuffle-deck) hands (deal players deck) [flop deck] (flop deck) [turn deck] (turn deck) [river deck] (river deck) player-hands (map #(conj % flop turn river) hands) winners (winner player-hands)] (println "Winning hand:" (best-hand (first winners))) (doseq [[hand player] (map vector player-hands players)] (println player "has" hand)) (doseq [w winners] (println (first w) "wins!")))) ``` 这个程序实现了一个简单的德州扑克游戏,包括洗牌、发牌、翻牌、转牌、河牌、计算最佳手牌和决定获胜者等功能。你可以在此基础上进行扩展,添加更多的游戏规则和功能。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值