PATA 1097 Deduplication on a Linked List(25 分)解题报告

 

1097 Deduplication on a Linked List(25 分)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10​5​​) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10​4​​, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

 

AC代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn=100010;
bool isExist[maxn]={0};//用于记录该数的绝对值是否已经访问过 
struct node{
	int add,data,next;
	int rank;
}res[maxn];
bool cmp(node a,node b);
int main()
{
	for(int i=0;i<maxn;i++)//先把rank都初始化完2*maxn,默认为全是无用结点 
		res[i].rank=2*maxn;
	int n,f;
	cin>>f>>n;
	int address,data,next;
	for(int i=0;i<n;i++)
	{
		cin>>address>>data>>next;
		res[address].add=address;
		res[address].data=data;
		res[address].next=next;
	}
	int cnt1=0,cnt2=0;
	int p=f;
	while(p!=-1)
	{
		int data=res[p].data;
		//cout<<"Now the data is"<<data<<endl;
		if(isExist[abs(data)]==false)//和之前访问的结点的数据都不一致 
		{
			res[p].rank=cnt1;
			cnt1++;
			isExist[abs(data)]=true;//标记已访问 
		}
		else//之前已经访问过同data的结点,删除该结点 
		{
			res[p].rank=cnt2+maxn;
			cnt2++;
		}
		p=res[p].next;//下一个结点 
		//cout<<"Now the next is "<<p<<endl;
	}
	sort(res,res+maxn,cmp);
	int cnt=cnt1+cnt2;
	for(int i=0;i<cnt;i++)
	{
		if(i!=cnt1-1&&i!=cnt-1)
			printf("%05d %d %05d\n",res[i].add,res[i].data,res[i+1].add);
		else
			printf("%05d %d -1\n",res[i].add,res[i].data);
	}
	return 0;
}

bool cmp(node a,node b)
{
	return a.rank<b.rank;
}
//算法的核心思想是把要删除的结点放后面,不需要删除的放在前面
//同类结点按照遍历次序来给定rank,删除结点从maxn开始排序,不需要删除则从0开始排序
//把两类结点分类好之后,按照rank进行由小到大排序
//按照之前记录好的数量输出 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值