PAT 7-5 Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

 

 这个题很麻烦, 输入的是字符串, 要涉及到字符串的判断和切割. 建完树之后再对树进行后续遍历

#include <stdio.h>
#include <stdlib.h>
typedef struct TNode* BinTree;
struct TNode {
	int Data;
	BinTree Left;
	BinTree Right;
};
typedef struct ListNode* List;
struct ListNode {
	int Index;
	List Next;
};

void push(List head,int a);
List pop(List head);
void postorderTraversal(BinTree root, int* cnt);

int main(void) {
	int num;
	scanf("%d", &num);
	struct TNode *TNode = (struct TNode*)malloc(sizeof(struct TNode) * (num + 1));
	for (int i=1; i<=num; i++) {
		TNode[i].Data = i;
		TNode[i].Left = NULL;
		TNode[i].Right = NULL;
	}
	BinTree root;
	int rootTree;
	BinTree *tnode = &root;
	List head = (List)malloc(sizeof(struct ListNode));
	head->Next = NULL;
	
	char a[5];
	int b;

	for (int i=0; i<2*num; i++) {
		scanf("%s", a);
		if (a[1] == 'u') {
			scanf("%d", &b);
			if (i == 0) {
				rootTree = b;
			}
			push(head, b);
			*tnode = &TNode[b];
//			printf("%d ",(*tnode)->Data);
			tnode = &((*tnode)->Left);
		} else {
			List tmp = pop(head);
			root = &TNode[tmp->Index];
			tnode = &(root->Right);
			free(tmp);
		}
	}
	int cnt = 0;
	postorderTraversal(&TNode[rootTree], &cnt);
	free(TNode);
	free(head);
	return 0;
}

void push(List head,int a) {
	List tmp = (List)malloc(sizeof(struct ListNode));
	tmp->Index = a;
	tmp->Next = head->Next;
	head->Next = tmp;
}

List pop(List head) {
	if (!head || !head->Next)
		return NULL;
	List tmp = head->Next;
	head->Next = tmp->Next;
	return tmp;
}

void postorderTraversal(BinTree root, int* cnt) {
	if (root) {
		postorderTraversal(root->Left, cnt);
		postorderTraversal(root->Right, cnt);
		if (*cnt) {
			printf(" ");
		}
		printf("%d", root->Data);
		(*cnt)++;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值