Be Good at Gaussing

Be Good at Gaussing

题目描述


 Give you many positive integer N (N<=23), for each N, just output N*(N+1)/2 integers in a single line, separated by space. (Don't ask me why.) For each N, the output line contains integers from 1 to N, and each just once. Again, do not ask me why, thank you. I'm so busy. But I can tell you a secret, the output has relationship with number triangle. As:(N=3)

                   1

                   2   6

                   3   4   5

See the sample for more information.

输入


a positive integer N (N<=23). 

输出


For each N, output N*(N+1)/2 integers in a single line, separated by a blank space. 

样例输入

3
4
2
6


样例输出

1 2 6 3 4 5
1 2 9 3 10 8 4 5 6 7
1 2 3
1 2 15 3 16 14 4 17 21 13 5 18 19 20 12 6 7 8 9 10 11

我的代码:


#include <stdio.h>
#include <stdlib.h>
void sovle(int n)
  {
   int a[24][24],i=1,j=1,e=1,num=0;  
    for(i=1;i<=n;i++)
    for(j=1;j<=i;j++)
    a[i][j]=0;
    i=0;j=1;
if(n==1)
   {
      a[1][1]=1;
   }


if(n>=2){
 
    while(a[i+1][j]==0)
 {i++;
  while( a[i][e]==0 && i<=n)
         {
          num++;
          a[i][e]=num;
          i++;
   }
  i--;
  while( a[i][j+1]==0 && j+1<=n)
         {
          num++;
          a[i][j+1]=num;
          j++;
   }
  
     while(a[i-1][j-1] ==0)
         {
          j--;i--;num++;
          a[i][j]=num;
   }
 e++;
 
    }
}  
    for(i=1;i<=n-1;i++)
    for(j=1;j<=i;j++)
    printf("%d ",a[i][j]);
    for(j=1;j<=i-1;j++)printf("%d ",a[i][j]);
    printf("%d",a[i][j]);
    printf("\n");
  }
int main(int argc, char *argv[]) {
 int n;
    while(scanf("%d",&n)!=EOF)
 {
     sovle(n);
    } 
    return 0;
}



  • 1
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值