【高效复习】算法合集(一)——贪心和递归

本文介绍了贪心算法在解决(PAT)A1067、A1038、A1033等题目中的应用,并提供了解题思路。递归部分讲解了全排列、八皇后问题及拆分自然数的方法。通过实例解析,帮助读者掌握算法的使用技巧。
摘要由CSDN通过智能技术生成

贪心算法

(PAT)A1067 Sort with Swap(0, i) (25 分)

*Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, ) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.
Input Specification:
Each input file contains one test case, which gives a positive N (≤10^​5) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

//核心1 数字存放该数字所在的位置,映射关系反置,有利于交换
//核心2 贪心,存放除0以外不在本位的最小数

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int maxn=100010;

int main()
{
   
    int pos[maxn];//核心1 数字存放该数字所在的位置,映射关系反置,有利于交换
    int n,ans=0;
    scanf("%d",&n);
    int left=n-1,num;
    for(int i=0;i<n;i++)
    {
   
        scanf("%d",&num);
        pos[num]=i;
        if(num==i && num!=0) left--;
    }
    int k=1;//核心2 贪心,存放除0以外不在本位的最小数
    while(left)
    {
   
        if(pos[0]==0)
        {
   
            while(k<n)
            {
   
                if(pos[k]!=k)
                {
   
                    swap(pos[0],pos[k]);
                    ans++;
                    break;
                }
                k++;
            }
        }
        while(pos[0]!=0)
        {
   
            swap(pos[0],pos[pos[0]]);
            ans++;
            left--;
        }
    }
    printf("%d",ans);


    return 0;
}

(PAT)A1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤10^4​​ ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值