OJ-3134 动态规划基础题目之数字三角形

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30
本题可采用从最底层向最高层递推的动态规划方法,即每一层的元素都与该元素对应的下一层左下和右下中较大的数相加,最后得到的就是最大的和。
#include<stdio.h>
#include<malloc.h>
int main()
{
    int n,a[100][100],i,j;
    scanf("%d",&n);
    for(i=0; i<n; ++i)
    {
        for(j=0; j<=i; ++j)
        {
            scanf("%d",&a[i][j]);
        }
    }
    for(i=n-1; i>1; --i)
    {
        for(j=0; j<i; ++j)
        {
          a[i-1][j]+=(a[i][j]>a[i][j+1])?a[i][j]:a[i][j+1];
          //j为当前层的上一层的横坐标
          //在当前层中比较两个数的大小,并将大的数加到相应的上一层的数上
        }
    }
    printf("%d",(a[0][0]+((a[1][0]>a[1][1])?a[1][0]:a[1][1])));
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值