YTU OJ 3134: 动态规划基础题目之数字三角形(Java解题)

198 篇文章 53 订阅

题目描述

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

输出

Your program is to write to standard output. The highest sum is written as an integer.

样例输入

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

样例输出

30

提示

这是动归题目,要有动归思维,即便是递归也需要一点改进。

来源

POJ



代码:

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner s = new Scanner(System.in);
		int n = s.nextInt();//输入行数
		int[][] a = new int[n + 1][n + 1];//储存二维数组中的数
		int[][] maxsum = new int[n + 1][n + 1];//储存所求的较大的数
		int i, j;
		for (i = 1; i <= n; i++) {
			for (j = 1; j <= i; j++) {
				a[i][j] = s.nextInt();//输入数据
			}
		}
		for (i = 1; i <= n; i++) {
			maxsum[n][i] = a[n][i];// 先将最后一行排列在相应位置
		}
		for (i = n - 1; i > 0; i--) {
			for (j = 1; j <= i; j++) {
				maxsum[i][j] = Math.max(maxsum[i + 1][j], maxsum[i + 1][j + 1])
						+ a[i][j];
			}// 上一行中的数选择下一行可以相加的两个数中较大的再加上这个数本身,逐行求解
		}
		System.out.println(maxsum[1][1]);
	}
}

说明:这道题目应该算是最简单的动态规划问题,是初学动态规划一个很好的基础练习。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值