华为-OSPF动态路由上网案例

网络技术 专栏收录该内容
2 篇文章 0 订阅

网络拓扑

在这里插入图片描述

组网说明

1、Cloud1连接本地网络,AR路由器自动获取IP
2、LSW1交换机OSPF与路由器组网
3、LSW2交换机OSPF与LSW1交换机1组网
4、PC1和PC2分配各自网段IP

效果

1、PC1与PC2互通
2、PC1和PC可以联网外网

在这里插入图片描述
在这里插入图片描述

配置

路由器配置

只配置Area0连接,其它通过路由引入直连,路由器配置默认路由

#
 sysname AR1
#
 dns resolve  
 dns server 223.5.5.5
#
vlan batch 188
#
dhcp enable
#
acl number 3999  
 rule 99999 permit ip 
#
interface Vlanif188
 ip address 192.168.88.1 255.255.255.252 
#
interface Ethernet0/0/0
 port link-type trunk
 port trunk allow-pass vlan 188
#
interface GigabitEthernet0/0/0
 nat outbound 3999
 ip address dhcp-alloc
#
ospf 1 
 default-route-advertise always
 import-route direct
 area 0.0.0.0 
  network 192.168.88.0 0.0.0.3 

LSW1配置

只配置Area0连接,其它通过路由引入直连。

#
sysname LSW1
#
dns resolve
dns server 223.5.5.5
#
vlan batch 90 188 to 189
#
interface Vlanif90
 ip address 192.168.90.1 255.255.255.0
#
interface Vlanif188
 ip address 192.168.88.2 255.255.255.252
#
interface Vlanif189
 ip address 192.168.88.5 255.255.255.252
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 90
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 188
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 189
#
ospf 1
 import-route direct
 area 0.0.0.0
  network 192.168.88.0 0.0.0.3
  network 192.168.88.4 0.0.0.3

LSW2配置

只配置Area0连接,其它通过路由引入直连。

#
sysname LSW2
#
vlan batch 91 189
#
interface Vlanif91
 ip address 192.168.91.1 255.255.255.0
#
interface Vlanif189
 ip address 192.168.88.6 255.255.255.252
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 91
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 189
#
ospf 1
 import-route direct
 area 0.0.0.0
  network 192.168.88.4 0.0.0.3

  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 打赏
    打赏
  • 扫一扫,分享海报

参与评论 您还未登录,请先 登录 后发表或查看评论
©️2022 CSDN 皮肤主题:游动-白 设计师:我叫白小胖 返回首页

打赏作者

`xifeng

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值