分治问题POJ1854_构造回文

题目

A palindrome is a string of symbols that is equal to itself when reversed. Given an input string, not necessarily a palindrome, compute the number of swaps necessary to transform the string into a palindrome. By swap we mean reversing the order of two adjacent symbols. For example, the string “mamad” may be transformed into the palindrome “madam” with 3 swaps:
swap “ad” to yield “mamda”
swap “md” to yield “madma”
swap “ma” to yield “madam”

Input

The first line of input gives n, the number of test cases. For each test case, one line of input follows, containing a string of up to 8000 lowercase letters.

Output

Output consists of one line per test case. This line will contain the number of swaps, or “Impossible” if it is not possible to transform the input to a palindrome.

Sample Input

3
mamad
asflkj
aabb

Sample Output

3
Impossible
2

import java.util.ArrayList;
import java.util.Scanner;

/**
 * Created by 95112 on 10/20/2017.
 */
public class POJA {
    public static void main(String[] args)
    {
        Scanner scanner = new Scanner(System.in);
        int n = scanner.nextInt();
        ArrayList<String> answers = new ArrayList<>();
        for (int i = 0 ; i< n; i++)
        {
            String input = scanner.next();
            int[] alphabet = new int[26];
            for (int j = 0; j < 26 ; j++)
                alphabet[j] = 0;
            for (char tmp: input.toCharArray()){
                alphabet[tmp - 'a']++;
            }
            int count = 0;
            for (int tmp : alphabet)
                if (tmp%2 == 1)
                    count++;
            if (count > 1)
            {
                answers.add("Impossible");
                continue;
            }
            char[] inputChar = input.toCharArray();
            int x = 0;
            int y = input.length()-1;
            int answer = 0;
            for ( ; x < input.length() && x < y ; x++,y--){
                int left = x;
                int right = y;
                for (;left < y; left++){
                    if (inputChar[left] == inputChar[y])
                        break;
                }
                for (; right > x ; right--){
                    if (inputChar[right] == inputChar[x])
                        break;
                }
                if (left - x > (y - right))
                {
                    char deal;
                    answer += (y - right);
                    for (int start = right ; start < y; start++ )
                    {
                        deal = inputChar[start+1];
                        inputChar[start+1] = inputChar[start];
                        inputChar[start] = deal;
                    }
                }
                else {
                    char deal;
                    answer += (left-x);
                    for (int start = left; start > 0 ; start--)
                    {
                        deal = inputChar[start];
                        inputChar[start] = inputChar[start-1];
                        inputChar[start-1] = deal;
                    }
                }

            }

            answers.add(String.valueOf(answer));

        }
        for (String answer : answers)
            System.out.println(answer);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值