动态规划K - 数塔 HDU - 2084 最经典入门

在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:
这里写图片描述

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?

已经告诉你了,这是个DP的题目,你能AC吗?
Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
Sample Input
1
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30

import java.util.ArrayList;
import java.util.Scanner;

/**
 * Created by 95112 on 10/28/2017.
 */
public class Stupa {
    public static void main(String[] args)
    {
        Scanner scanner = new Scanner(System.in);
        ArrayList<String> answers = new ArrayList<>();
        int C = scanner.nextInt();
        for (int i = 0 ; i < C ; i++)
        {
            int N = scanner.nextInt();
            int[][] stupa = new int[N][N];
            for (int x = 0 ; x < N;x++ )
                for (int y = 0 ; y <=x ; y++){
                  stupa[x][y] = scanner.nextInt();
                }
            for (int x = N-2; x >=0 ; x--)
                for (int y =0; y <=x ;y++ ){
                    stupa[x][y] = max(stupa[x+1][y],stupa[x+1][y+1])+stupa[x][y];
                }
            answers.add(stupa[0][0]+"");
        }
        for (String answer : answers)
            System.out.println(answer);
    }
    private static int  max (int a, int b)
    {
        if (a>b)
            return a;
        else
            return b;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值