Java动态规划模板 P - Coins HDU - 2844

解这道题的时候涉及了多重背包和完全背包,就写了一个Java动态规划模板

Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4

import java.util.ArrayList;
import java.util.Scanner;

/**
 * Created by 95112 on 11/2/2017.
 */
public class DP {
    static int dp[];
    static int a[];
    static int b[] ;

//m背包的总容量、v物品的体积、w物品的价值 01背包
    static void OneZeroPack(int m , int v , int w)
    {
        for (int i = m ; i>=v;i--){
            dp[i] = max(dp[i],dp[i-v]+w);
        }
    }
    //m背包的总容量、v物品的体积、w物品的价值 完全背包
    static void CompletePack(int m,int v,int w)
    {
        for (int i = v ; i<=m;i++)
        {
            dp[i] = max(dp[i], dp[i-v]+w);
        }
    }
//m背包的总容量、v物品的体积、w物品的价值 num物体数量 多重背包
    static void MultiplePack(int m,int v, int w,int num){
        if (v*num >= m)
        {
            CompletePack(m,v,w);
            return;
        }
        int k = 1;
        for (k=1; k <=num; k<<=1){
            OneZeroPack(m,k*v,k*w);
            num = num - k;
        }
        if (num>0){
            OneZeroPack(m,v*num,w*num);
        }

    }

    public static void main(String[] args)
    {
        Scanner scanner = new Scanner(System.in);
        ArrayList<String> answers = new ArrayList<>();
        int n, m;
        do {
            n = scanner.nextInt();
            m = scanner.nextInt();
            if (n == 0 && m == 0)
                break;
            dp = new int[1111111];
            a = new int[111];
            b = new int[111];
            for (int i =0 ; i < n;i++)
                a[i] = scanner.nextInt();
            for (int i = 0; i < n;i++)
                b[i] = scanner.nextInt();
            for (int i = 0; i < n;i++)
            {
                MultiplePack(m,a[i],a[i],b[i]);
            }
            int sum = 0;
            for (int i= 1; i<= m;i++)
                if (dp[i] == i)
                    sum++;
            answers.add(sum+"");
        }while (true);
        for (String answer : answers)
            System.out.println(answer);
    }
    static int max(int a,int b)
    {
        if (a>b)
            return a;
        else
            return b;
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值