HDU---2586-How far away(LCA)

48 篇文章 0 订阅
42 篇文章 0 订阅

How far away ?Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

Input

First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

Sample Input

     
     
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 

Sample Output

     
     
10 25 100 100
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
using namespace std;
#define SIZE 45000
int n,m;
int head[SIZE<<1];
bool vis[SIZE];
int set[SIZE];
int dis[SIZE];
int x[SIZE],y[SIZE],z[SIZE];
struct Edge
{
    int b,c,next;
} edge[SIZE<<1];
int poi=0;
void link_node(int a,int b,int c)
{
    edge[poi].b=b;
    edge[poi].c=c;
    edge[poi].next=head[a];
    head[a]=poi++;
}
int set_find(int p)
{
    if(set[p]==-1)return p;
    return set_find(set[p]);
}
void Tarjan(int p)
{
    int i;
    vis[p]=1;
    for(i=0; i<m; ++i)
    {
        if(x[i]==p && vis[ y[i] ])z[i]=set_find(y[i]);
        if(y[i]==p && vis[ x[i] ])z[i]=set_find(x[i]);
    }
    for(i=head[p]; i!=-1; i=edge[i].next)
    {
        if(!vis[edge[i].b])
        {
            dis[edge[i].b]=edge[i].c + dis[p];
            Tarjan(edge[i].b);
            set[edge[i].b]=p;
        }
    }
}
int main()
{
    int T;
    int a,b,c,i,j,k;
    cin>>T;
    while(T--)
    {
        memset(head,-1,sizeof(head));
        memset(set,-1,sizeof(set));
       // memset(x,0,sizeof(x));
       // memset(y,0,sizeof(y));
        memset(z,0,sizeof(z));
        memset(vis,0,sizeof(vis));
        scanf("%d%d",&n,&m);
        poi=0;
        for(i=1; i<n; ++i)
        {
            scanf("%d%d%d",&a,&b,&c);
            link_node(a,b,c);
            link_node(b,a,c);
        }
        for(i=0; i<m; ++i)
        {
            scanf("%d%d",&a,&b);
            x[i]=a,y[i]=b;
        }
        dis[1]=0;
        Tarjan(1);
        for(i=0; i<m; ++i)
            printf("%d\n",dis[ x[i] ] + dis[ y[i] ] - (dis[ z[i] ]<<1));
    }
    return 0;
}







  
    
      






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值