Slim Span UVA - 1395

Given an undirected weighted graph G, youshould find one of spanning trees specified as follows.The graph G is an ordered pair (V, E), whereV is a set of vertices {v1, v2, . . . , vn} and E is aset of undirected edges {e1, e2, . . . , em}. Eachedge e ∈ E has its weight w(e).A spanning tree T is a tree (a connected subgraphwithout cycles) which connects all the nvertices with n−1 edges. The slimness of a spanningtree T is defined as the difference betweenthe largest weight and the smallest weight among the n − 1 edges of T.For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges{e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7as shown in Figure 5(b).Figure 6: Examples of the spanning trees of GThere are several spanning trees for G. Four of them are depicted in Figure 6(a)(d). The spanningtree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and thesmallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tcand Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimnessof any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is oneof the slimmest spanning trees whose slimness is 1.Your job is to write a program that computes the smallest slimness.InputThe input consists of multiple datasets, followed by a line containing two zeros separated by a space.Each dataset has the following format.n ma1 b1 w1...am bm wmEvery input item in a dataset is a non-negative integer. Items in a line are separated by a space.n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, . . . , m) are positive integers less than or equal to n, whichrepresent the two vertices vakand vbkconnected by the k-th edge ek. wk is a positive integer less thanor equal to 10000, which indicates the weight of ek. You can assume that the graph G = (V, E) issimple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are twoor more edges whose both ends are the same two vertices).OutputFor each dataset, if the graph has spanning trees, the smallest slimness among them should be printed.Otherwise, ‘-1’ should be printed. An output should not contain extra characters.Sample Input4 51 2 31 3 51 4 62 4 63 4 74 61 2 101 3 1001 4 902 3 202 4 803 4 402 11 2 13 03 11 2 13 31 2 22 3 51 3 65 101 2 1101 3 1201 4 1301 5 1202 3 1102 4 1202 5 1303 4 1203 5 1104 5 1205 101 2 93841 3 8871 4 27781 5 69162 3 77942 4 83362 5 53873 4 4933 5 66504 5 14225 81 2 12 3 1003 4 1004 5 1001 5 502 5 503 5 504 1 1500 0Sample Output1200-1-110168650
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define MAX 2000000000
int b[10000][10000],c[10001];
struct STR
{
    int x,y,p;
} a[10001];
int find(int m)
{
    if(c[m]==m)
        return m;
    else
        return find(c[m]);
}
void merge(int x,int y)
{
    int fx,fy;
    fx=find(x);
    fy=find(y);
    if(fx>fy)
    {
        c[fx]=fy;
    }
    else
        c[fy]=fx;
}
bool comp(STR q,STR w)
{
    return q.p<w.p;
}
int main()
{
    int n,z,m,i,j,k,sum,min;
    while(scanf("%d%d",&n,&m)&&(m!=0||n!=0))
    {
        memset(b,-1,sizeof(b));
        for(i=0; i<m; i++)
            scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].p);
        sort(a,a+m,comp);
        for(i=0; i<m-n+2; i++)
        {
            k=0;memset(c,0,sizeof(c));
           for(z=0;z<n;z++){c[z]=z;}
            for(j=i; j<m; j++)
            {
                if(find(a[j].x)!=find(a[j].y))
                {
                    merge(a[j].x,a[j].y);
                    b[i][k]=a[j].p;
                    k++;
                }
            }
        }
        min=MAX;
        for(i=0; i<m-n+2; i++)
        {
            sum=b[i][n-2]-b[i][0];
            if(sum>=0&&sum<min)
                min=sum;
        }
        if(min==MAX)
            printf("-1\n");
        else
        printf("%d\n",min);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值