Max Sum Plus Plus HDU - 1024(dp)

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S  1, S  2, S  3, S  4 ... S  x, ... S  n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S  x ≤ 32767). We define a function sum(i, j) = S  i + ... + S  j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i  1, j  1) + sum(i  2, j  2) + sum(i  3, j  3) + ... + sum(i  m, j  m) maximal (i  x ≤ i y ≤ j  x or i  x ≤ j  y ≤ j  x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i  x, j  x)(1 ≤ x ≤ m) instead. ^_^ 
Input
Each test case will begin with two integers m and n, followed by n integers S  1, S 2, S  3 ... S  n
Process to the end of file. 
Output
Output the maximal summation described above in one line. 
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8


        
  
Hint

Huge input, scanf and dynamic programming is recommended.


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define max(a,b) (a>b?a:b)
#define MAX 1000001
#define INF 0x7fffffff
 int dp[3][MAX];
 int w[MAX];
 int sum[MAX];
int main()
{
    int n,m,i,j,k;
    while(~scanf("%d%d",&m,&n))
    {
        sum[0]=0;
        for(i=1;i<=n;i++)
        {
            cin>>k;
            sum[i]=sum[i-1]+k;
            dp[0][i]=0;
        }
        for(i=1;i<=m;i++)
        {
            for(j=i;j<=n;j++)
            {
                if(j==i)
                {
                    dp[i%2][j]=sum[i];
                    w[j]=sum[i];
                }
                else
                {
                    w[j]=max(dp[(i+1)%2][j-1],w[j-1])+sum[j]-sum[j-1];
                    dp[i%2][j]=max(dp[i%2][j-1],w[j]);
                
                }
            }
        }
        cout<<dp[m%2][n]<<endl;
    }
   return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值