Balanced Lineup (树状数组 时间???)

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 80158 Accepted: 36581
Case Time Limit: 2000MS
Description

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2…N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output

Lines 1…Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output

6
3
0
Source

USACO 2007 January Silver

//树状数组 卡时间

#pragma warning(disable:4996)
#include"iostream"
#include"algorithm"
#include"string.h"
#include"map"
using namespace std;
const int maxn = 50009;
int n, q;
int a[maxn],vis[maxn];
struct node {
	int mi, ma;
}h[maxn];
int lowbit(int x) {
	return x & -x;
}
void ad(int x) {
/*
	for (int i = x; i <= maxn; i += lowbit(i)) {
		h[i].mi = a[i];
		h[i].ma = a[i];
		for (int j = 1; j < lowbit(i); j <<= 1) {
			h[i].ma = max(h[i].ma, h[i - j].ma);
			h[i].mi = min(h[i].mi, h[i - j].mi);
		}

	}
*/
    //第二个循环不需要嵌套  省时间
	h[x].mi = a[x];
	h[x].ma = a[x];
	for (int j = 1; j < lowbit(x); j <<= 1) {
		h[x].ma = max(h[x].ma, h[x - j].ma);
		h[x].mi = min(h[x].mi, h[x - j].mi);
	}
	for (int i = x; i <= maxn; i += lowbit(i)) {
		h[i].ma = max(h[i].ma, a[x]);
		h[i].mi = min(h[i].mi, a[x]);
	}
}

void as( int y,int x) {
	h[0].ma =a[x];
	h[0].mi =a[x];
	while (x >= y) {
	    //嵌套循环 省时间 防止 x -= lowbit(x); 失效
		while (x - lowbit(x) >= y) {
			h[0].ma = max(h[x].ma, h[0].ma);
			h[0].mi = min(h[x].mi, h[0].mi);
			x -= lowbit(x);
		}
		h[0].ma = max(a[x], h[0].ma);
		h[0].mi = min(a[x], h[0].mi);
		x--;

	}

}

int main() {

		scanf("%d%d", &n, &q);
		int ans = 0;
		for (int i = 1; i <= n; i++) {
			scanf("%d", &a[i]);
			ad(i);
		}
		for (int i = 0; i < q; i++) {
			int v, b;
			scanf("%d%d", &v, &b);
			as(v, b);
			printf("%d\n", h[0].ma - h[0].mi);
		}
		

}

/优化

#include"iostream"
#include"string.h"
#include"stdio.h" 
#include"map"
using namespace std;
const int maxn=1e6+9;
int  g[maxn],ma[maxn],mi[maxn],n;
int lowbit(int x){
	return x&-x;
}
void update(int x){
	ma[x]=g[x];
	mi[x]=g[x];
	for(int i=1;i<lowbit(x);i<<=1){
		ma[x]=max(ma[x-i],ma[x]);
		mi[x]=min(mi[x-i],mi[x]);
	}
}
int solve(int l,int r){
	int mx,m;
	mx=m=g[l];
	while(r>=l){
		while(r-lowbit(r)>=l){
			mx=max(mx,ma[r]);
			m=min(m,mi[r]);
			r-=lowbit(r);
		}
		mx=max(mx,g[r]);
		m=min(m,g[r]);
		r--;	
	}
	return mx-m;
	
}
int main(){
	int a,b,l,r;
	scanf("%d%d",&a,&b);
	for(int i=1;i<=a;i++){
		scanf("%d",&g[i]);
		update(i);	
	}
	for(int i=1;i<=b;i++){
		scanf("%d%d",&l,&r);
		printf("%d\n",solve(l,r));	
	}

}

/线段树

#include"iostream"
#include"string.h"
#include"stdio.h" 
#include"map"
using namespace std;
const int maxn=1e7+9;
int  g[maxn],ma[maxn],mi[maxn],n,l[maxn],r[maxn];

void update(int cnt,int x,int y){
	l[cnt]=x;
	r[cnt]=y;
	if(x==y) {
		ma[cnt]=g[x];
		mi[cnt]=g[x];
		return;
	}
	int mid=x+y>>1;
	update(cnt*2,x,mid);
	update(cnt*2+1,mid+1,y);
	ma[cnt]=max(ma[cnt*2],ma[cnt*2+1]);
	mi[cnt]=min(mi[cnt*2],mi[cnt*2+1]);

}
void solve(int cnt,int x,int y,int &mx,int &m){
	
	if(l[cnt]>=x&&y>=r[cnt]){
		mx=max(mx,ma[cnt]);
		m=min(m,mi[cnt]);
		return;
	}
	int mid=l[cnt]+r[cnt]>>1;
	if(x<mid)solve(cnt*2,x,y,mx,m);
	if(y>mid)solve(cnt*2+1,x,y,mx,m);	
}
int main(){
	int a,b,l,r;
	cin>>a>>b;
	for(int i=1;i<=a;i++){
		scanf("%d",&g[i]);
	}
	update(1,1,a);
	for(int i=1;i<=b;i++){
		scanf("%d%d",&l,&r);
		int mx,m;
		mx=m=g[l];
		solve(1,l,r,mx,m);
		printf("%d\n",mx-m);	
	}

}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值