1042. Shuffling Machine (20)

huffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题意:

题目的要求是按照给定的序列将扑克重新排列给定的次序,所以首先需要一个序列用来存储给定交换次序,还有需要一个存储每次开始交换之前的扑克的次序以及交换完成之后的次序,最后按照交换完成之后的次序输出即可

一、起始变量

1、next[]用来存储交换序列

2、start[]用来存储每次交换之前的起始序列

3、end[]用来存储每次交换完成之后的序列

4、K交换次数

二、思路

1、首先存储好交换次数和交换序列

2、初始化好起始序列

3、将start[i]赋值给end[next[i]],即将start序列按照给定的next交换序列进行交换,结果存入end序列

4、输出end

三、注意:

1、构造字符型数组mp={'S','H','C','D','J'}将要输出的元素x按照mp[(x-1)/13]输出对应花色

2、(x-1)%13+1为对用牌号

四、代码:

#include <iostream>
#include <cstdio>


using namespace std;




int main()
{
const int N = 54;
int start[N + 1], end[N + 1], next[N + 1];
char mp[5] = {'S', 'H', 'C', 'D', 'J'};


int K;
scanf("%d", &K);
for(int i = 1; i <= N; i++)
{
start[i] = i;
}

for(int i = 1; i <= N; i++)
{
scanf("%d", &next[i]);
}
for(int i = 0; i < K; i++)
{
for(int j = 1; j <= N; j++)
{
end[next[j]] = start[j];
}
for(int k = 1; k <= N; k++)
{
start[k] = end[k];
}
}
for(int i = 1; i <= N; i++)
{
if(i != 1)
printf(" ");
start[i]--;
printf("%c%d", mp[start[i] / 13], start[i] % 13 + 1);
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值