Codeup 墓地——3.6.问题 A: 字符串连接

题目描述

不借用任何字符串库函数实现无冗余地接受两个字符串,然后把它们无冗余的连接起来。

输入

每一行包括两个字符串,长度不超过100。

输出

可能有多组测试数据,对于每组数据,
不借用任何字符串库函数实现无冗余地接受两个字符串,然后把它们无冗余的连接起来。
输出连接后的字符串。

样例输入

abc def

样例输出

abcdef
#include <stdio.h>
#include <iostream>
#include <string.h>
const int maxn = 100;
int main(){
	char str1[100],str2[100];
	while (scanf("%s%s", str1,str2) != EOF){
		char str[200] ;
		int i = 0, j=0;
		while (str1[i] != 0){
			i++;
		}
		while (str2[j] != 0){
			j++;
		}
		//printf("%s%s", str1, str2);
		//printf(" %d %d ", i, j);
		int k1 = 0,k2=0;
		for (k1; k1 < i; k1++){
			str[k1] = str1[k1];
		}
		for (k1, k2; k2 < j; k2++,k1++){
			str[k1] = str2[k2];
		}
		str[k1] = '\0';//注意要在字符串加上空字符‘\0’,以便printf识别字符串的结尾
		printf("%s", str);
		printf("\n");

	}
	//system("pause");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值