Gradle读取package.json

版权声明:本文为博主原创文章,未经博主允许不得转载的哦=。= https://blog.csdn.net/qq_15602635/article/details/82230355

ReactNative项目中,ReactNative版本配置在package.json文件中,另外Android的build.gradle中也需要配置相应的版本。

所以能不能只配置一处呢?方法就是gralde中读取package.json的react-native的版本号。代码如下:

String reactVersion
def jsonFile = file('../package.json')
def json = new JsonSlurper().parseText(jsonFile.text)
reactVersion = json.dependencies["react-native"]
println "getReactNativeVersion = " + reactVersion

以上代码仍有不完善的地方,没有兼容一些符号。package.json中版本号可以配置一些符号表示有新版本时自动使用新版本。

没有更多推荐了,返回首页

私密
私密原因:
请选择设置私密原因
  • 广告
  • 抄袭
  • 版权
  • 政治
  • 色情
  • 无意义
  • 其他
其他原因:
120
出错啦
系统繁忙,请稍后再试

关闭