从github下载开发者版本的源码进行编译安装scikit-image(0.14)

有时候,我们会在尚未发布的开发者版本中,发现某些包中有添加了许多令人惊奇的新功能,例如图片处理库scikit-image(0.14),目前为止,发行的最新版本为:0.13.1,其中的draw模块中只能画polygon而不能直接画矩形,但是0.14版本就添加了画矩形的功能,但是目前0.14版本的scikit-image还没有现成的.WHL,只能下载github上的源码进行编译,从而安装该开发者版本!

1. 开发者版本安装:

a. Windows

在安装新版本之前, 首先需要卸载scikit-image(pip用户):

pip uninstall scikit-image

conda(Anaconda用户):

conda uninstall scikit-imag

从github上clone下来源码:

git clone https://github.com/scikit-image/scikit-image.git

在CMD窗口中,使用CD命令转到scikit-image文件夹下:

cd scikit-image
python setup.py develop

如果你的编译工具完全的话,直接运行:

pip install -U -e .

如果编译工具不完全的话,建议下载安装微软的编译器:

点击打开链接

在安装之后,可以安装或升级scikit-image所需的依赖项:

pip install -r requirements.txt --upgrade


b. Debian and Ubuntu

安装所有必需的依赖项:

sudo apt-get install python-matplotlib python-numpy python-pil python-scipy

使用已经安装好的的编译器:

sudo apt-get install build-essential cython

从github上clone下来源码::

git clone https://github.com/scikit-image/scikit-image.git

解压之后,转到scikit-image文件夹下,并且执行:

pip install -e .

更新:

git pull  # Grab latest source
python setup.py build_ext -i  # Compile any modified extensions

阅读更多
上一篇类别名称转换为一一对应的数字标签
下一篇win10下安装Tensorflow1.7+CUDA9.0+Cudnn7.0.3
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭