Max Sum
Time Limit: 2000ms Memory limit: 32768K 有疑问?点这里^_^
题目描述
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
示例输入
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
示例输出
Case 1: 14 1 4 Case 2: 7 1 6
提示
hdoj1003 注意:本题后台测试数据量比较大,请使用C语言scanf输入。避免超时!!!!
又是一道很经典的dp,题意是让求最大连续字段和 不难写出状态转移方程 dp[i]=max(dp[i-1]+i,i);
#include <cstdio>
int a[100001];
int main()
{
int t,n,i,j,k;
scanf("%d",&t);
for(i=1;i<=t;i++)
{
scanf("%d",&n);
for(j=0;j<n;j++)
scanf("%d",&a[j]);
int sum=0,max=-99999,k=0,pos1,pos2;
for(j=0;j<n;j++)
{
sum+=a[j];
if(sum>max)
{
max=sum;
pos1=k;
pos2=j;
}
if(sum<0)
{
k=j+1;
sum=0;
}
}
printf("Case %d:\n",i);
if(i!=t)
printf("%d %d %d\n\n",max,pos1+1,pos2+1);
else
printf("%d %d %d\n",max,pos1+1,pos2+1);
}
return 0;
}