POJ 3125 Printer Queue(单链表)

Description

The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output. 

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, 
and 1 being the lowest), and the printer operates as follows.
  • The first job J in queue is taken from the queue.
  • If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
  • Otherwise, print job J (and do not put it back in the queue).
In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life. 

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:
  • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
  • One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Sample Input

3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1

Sample Output

1
2
5
题目大意是给定一个数n代表需要总共需要打印的物品的个数,一个m代表你的要打印的物品的位置,比如0就是第一个,1是第二个,依次类推。下一行给n个数代表这些物品的优先级,因为每次只能打印队首的物品,所以对于队首元素,先扫一遍整个队列,如果有比它优先级高的物品,就把队首元素移到队尾(操作①),这个过程是瞬间完成的,不加时间,如果队首元素是优先级最高的,那么就把它移走,相当于删除队首(操作②),这个操作消耗1分钟,求的是你的物品被打印需要多少分钟。
因为昨天刚学链表。就用链表模拟的,操作①是让链表尾接到头结点,头结点变尾节点,头指针接到第二个节点。
操作②是删除头结点。

#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
typedef struct node //单链表
{
	int date;//优先级
	int pos; //位置
	node *next;
}*S,list;
void create_list(S head,int n)
{
	S p=head,t;
	for(int i=0;i<n;i++)
	{
		t=new list;
		cin>>t->date;
		t->pos=i;
		t->next=NULL;
		p->next=t;
		p=t;
	}
}
S get_end_list(S head)//获得链表的尾指针
{
	S p=head;
	while(p->next!=NULL)

		p=p->next;
	return p;
}
int main()
{
	int T,n,m;
	cin>>T;
	while(T--)
	{
		cin>>n>>m;
		S t,p,head=new list;
		head->next=NULL;
		head->date=-1;head->pos=-1;
		create_list(head,n);
		int cnt=0;
		while(1)
		{
			p=head->next;
			int flag=0;
			while(p!=NULL)
			{
				if(p->date>head->next->date)
				{
					flag=1;break;
				}
				p=p->next;
			}
			if(flag) //把第一个节点接到尾,然后把头指针指向第二个节点
			{
				t=head->next;
				head->next=head->next->next;
				t->next=NULL;
				get_end_list(head)->next=t;
			}
			else  //直接删除第一个节点,时间加一
			{
				cnt++;
				if(head->next->pos==m)break;
				head->next=head->next->next;
			}
		}
		cout<<cnt<<endl;

	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值