Array - Finding Missing Cards

题目描述

Finding Missing Cards

Taro is going to play a card game. However, now he has only n cards, even though there should be 52 cards (he has no Jokers).

The 52 cards include 13 ranks of each of the four suits: spade, heart, club and diamond.

输入
In the first line, the number of cards n (n ≤ 52) is given.

In the following n lines, data of the n cards are given. Each card is given by a pair of a character and an integer which represent its suit and rank respectively. A suit is represented by ‘S’, ‘H’, ‘C’ and ‘D’ for spades, hearts, clubs and diamonds respectively. A rank is represented by an integer from 1 to 13.

输出
Print the missing cards. The same as the input format, each card should be printed with a character and an integer separated by a space character in a line. Arrange the missing cards in the following priorities:

Print cards of spades, hearts, clubs and diamonds in this order.

If the ranks are equal, print cards with lower ranks first.

样例输入

47
S 10
S 11
S 12
S 13
H 1
H 2
S 6
S 7
S 8
S 9
H 6
H 8
H 9
H 10
H 11
H 4
H 5
S 2
S 3
S 4
S 5
H 12
H 13
C 1
C 2
D 1
D 2
D 3
D 4
D 5
D 6
D 7
C 3
C 4
C 5
C 6
C 7
C 8
C 9
C 10
C 11
C 13
D 9
D 10
D 11
D 12
D 13

样例输出

S 1
H 3
H 7
C 12
D 8

示例代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    cin >> n;
    char ch;
    int a[4][13], j0 = 0, j1 = 0, j2 = 0, j3 = 0;
    fill(a[0], a[0] + 52, 0);
    for (int i = 0; i < n; i++)
    {
        cin >> ch;
        if (ch == 'S')
        {
            cin >> a[0][j0];
            ++j0;
        }
        else if (ch == 'H')
        {
            cin >> a[1][j1];
            ++j1;
        }
        else if (ch == 'C')
        {
            cin >> a[2][j2];
            ++j2;
        }
        else
        {
            cin >> a[3][j3];
            ++j3;
        }

    }
    sort(a[0], a[0] + j0);
    sort(a[1], a[1] + j1);
    sort(a[2], a[2] + j2);
    sort(a[3], a[3] + j3);
    for (int i = 1, j = 0; i <= 13; i++)
    {
        if (a[0][j] != i)
            cout << "S " << i << endl;
        else
            ++j;
    }
    for (int i = 1, j = 0; i <= 13; i++)
    {
        if (a[1][j] != i)
            cout << "H " << i << endl;
        else
            ++j;
    }
    for (int i = 1, j = 0; i <= 13; i++)
    {
        if (a[2][j] != i)
            cout << "C " << i << endl;
        else
            ++j;
    }
    for (int i = 1, j = 0; i <= 13; i++)
    {
        if (a[3][j] != i)
            cout << "D " << i << endl;
        else
            ++j;
    }
    return 0;
}
  • 4
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值