利用str.find函数找子串

题目描述

给定原子串和目标子串,要你求得目标子串在原子串当中出现的次数。

输入
多组测试数据,每组测试数据第一行是原子串,第二行是目标子串
子串长度不会超过100.

输出
输出目标子串在原子串当中出现的次数。

样例输入

abc123abc
abc
aabcCdeAbcAbcdeccde
cde

样例输出

2
2

示例代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string s1, s2;
    while (cin >> s1 >> s2)
    {
        int len1 = s1.size();
        int len2 = s2.size();
        int cnt = 0;
        for (int i = 0; i <= len1 - len2; i++)
        {
            int Find = s1.find(s2, i);
            if (Find > -1)
            {
                ++cnt;
                i = Find;
            }
        }
        cout << cnt << endl;
    }
    return 0;
}

另附

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string s1, s2;
    while (cin >> s1 >> s2)
    {
        int len1 = s1.size();
        int len2 = s2.size();
        int cnt = 0;
        for (int i = 0; i <= len1 - len2; i++)
        {
            if (s1.find(s2, i)!=std::string::npos)
            {
                ++cnt;
                i = s1.find(s2, i);
            }
        }
        cout << cnt << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值