LightOj 1282 Leading and Trailing(快速幂取模 + 对数)

原题链接:传送门

Description


You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input


Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output


For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input


5
123456 1
123456 2
2 31
2 32
29 8751919

Sample Output


Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296
Case 5: 665 669


题意:

给你两个数 n 和 k,让你求出n^k的前三位和最后三位的数

思路:

后三位好求点,用快速幂取模1000,就得到后三位了,但要注意模后不满三位要补上前导零。
前三位的话可以用对数来求。任意一个数n可以写成10a的形式,a为小数,则10a = 10x+y = 10x * 10y,其中x为整数,控制着n的位数,y为小数,决定着n的位数上的值。
log10nk = k*log10n = a,fmod(a,1) 就是求a的小数部分y——决定n的位数上的值。再用pow(10,2+y),就是nk的前三位的值了。

数学真的很奇妙啊

PS:fmod(a,b)是对浮点数取余的函数,即a%b的值。其库函数是<math.h>
#include <bits/stdc++.h>
#include <cmath>
using namespace std;
typedef long long ll;

ll Pow(ll a,ll b,ll Mod){
    ll r = 1,base = a;
    while(b){
        if(b&1)
            r = base * r % Mod;
        base = base * base % Mod;
        b >>= 1;
    }
    return r % Mod;
}

int main(){
    int t;
    int n,k;
    int Case = 1;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&k);

        int first = pow(10.0 , 2.0 + fmod( k*log10(n*1.0) , 1) );
        int last = Pow(n % 1000 ,k ,1000);

        printf("Case %d: %d %03d\n",Case++,first,last);

    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值