HDU 2736 Surprising Strings

Surprising Strings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 349    Accepted Submission(s): 245


Problem Description
The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.
 

Input
The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.
 

Output
For each string of letters, output whether or not it is surprising using the exact output format shown below.
 

Sample Input
  
  
ZGBG X EE AAB AABA AABB BCBABCC *
 

Sample Output
  
  
ZGBG is surprising. X is surprising. EE is surprising. AAB is surprising. AABA is surprising. AABB is NOT surprising. BCBABCC is NOT surprising.
 

题意:
     举例说明,如ZGBG,先取相邻的对,ZG,GB,GB,没有相同的,再取隔一个的对,
ZB,BG,也没有相同的,最后取首尾的对,ZG,也不会有相同的,输出ZGBG is surprising.
若至少有一行存在相同的对,输出%s is NOT surprising.
#include <iostream>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<string>
#include<stdlib.h>
#include<algorithm>
#include<map>
#include<queue>
using namespace std;
char str[81];
int main()
{
    int i,j;
    while(scanf("%s",str)!=EOF)
    {
        if(strcmp(str,"*")==0)
            break;
        int len=strlen(str);
        if(len<=2)//若字符串有一个或两个字符,肯定没有重复的
        {
            printf("%s is surprising.\n",str);
            continue;
        }
        bool k=1;//初始化k
        for(i=1;i<len;i++)
        {
            map<string,bool>q;
            bool flag=1;
            for(j=0;j<len-1&&i+j<len;j++)
            {
                string st;
                st=st+str[j];
                st=st+str[i+j];
                if(q[st])
                {
                    flag=0;
                    break;
                }
                else
                q[st]=1;
            }
            if(!flag)
            {
                k=0;
                break;
            }
        }
        if(k)
        printf("%s is surprising.\n",str);
        else
        printf("%s is NOT surprising.\n",str);

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值