POJ 1442 Black Box

Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8052 Accepted: 3297

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

题意:给定一个序列,每次插入其中的一个数,给出另一个序列,序列中的每一个数表示插入第一个序列的第几个数的时候输出第Rank小的数,其中k表示第几次输出,因为每插入一个数后都要让数据有序,因此用到了优先队列

开始用了一个优先队列,用G++交WA,用C++交TLE了。

这道题用了两个优先队列,第一个存放前Rank小的数,由大到小,第二个存放第Rank+1小的数到最大的数,当插入一个数的时候,若第一个队列大小等于Rank,把这个数存入第二个优先队列,取第二个优先队列的队首元素放入第一个优先队列;若是第一个优先队列的大小不小于Rank,且这个数比其队首元素小,将队首元素放入第二个优先队列,这个数放入第一个优先队列,如果这个数比第一个优先队列的队首元素大,则直接放入第二个优先队列。输出的时候,若第一个优先队列的大小不够Rank,将第二个优先队列的元素存入第一个优先队列,直至大小等于Rank,需要注意的是每次输出后记得将Rank+1

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>

using namespace std;

int main()
{
    int n,m;
    int a[30010],b[30010];
    scanf("%d%d",&n,&m);
    for(int i=1; i<=n; i++)
    {
        scanf("%d",&a[i]);
    }
    for(int j=1; j<=m; j++)
    {
        scanf("%d",&b[j]);
    }
    priority_queue<int,vector<int>,less<int> >q1;//从大到小排序
    priority_queue<int,vector<int>,greater<int> >q2;//从小到大排序
    int Rank=1;
    int i=0;
    int j=1;
    while(j<=m)
    {
        if(i==b[j])//输出第Rank小的数
        {
            j++;
            while(q1.size()<Rank)//q1中不够Rank个元素,把q2中的队首元素放入q1
            {
                int s=q2.top();
                q1.push(s);
                q2.pop();
            }
            printf("%d\n",q1.top());
            Rank++;//每输出一个数Rank+1
        }
        else
        {
            i++;
            if(q1.size()<Rank)//q1中元素不足Rank,先将这个数放入q2,再把q2的队首元素放入q1
            {
                q2.push(a[i]);
                int x=q2.top();
                q1.push(x);
                q2.pop();
            }
            else if(a[i]<q1.top())//要放的数比q1中的队首元素小,将q1队首元素放入q2,这个数存入q1
            {
                int x=q1.top();
                q2.push(x);
                q1.pop();
                q1.push(a[i]);
            }
            else
            {
                q2.push(a[i]);//要放的数比q1中的队首元素大,直接存入q2
            }
        }
    }
    return 0;
}

错误代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>

using namespace std;

int main()
{
    int n,m;
    int ss;
    int a[30010],b[30010];
    memset(a,0,sizeof(a));
    scanf("%d%d",&n,&m);
    for(int i=0; i<n; i++)
    {
        scanf("%d",&a[i]);
    }
    priority_queue<int,vector<int>,greater<int> >q;
    q.push(a[0]);
    int Rank=0;
    int i=0;
    int j=0;
    int t,l;
    scanf("%d",&ss);
    while(i<n)
    {
        while(i+1==ss)
        {
        	Rank++;
        	l=Rank;
        	j=0;
        	memset(b,0,sizeof(b));
            while(l>0)
            {
                //int t;
                t=q.top();
                q.pop();
                b[++j]=t;
                l--;
            }
            printf("%d\n",t);
            scanf("%d",&ss);
            m--;
            while(j>0)
			{
				q.push(b[j]);
				j--;
			}
        }
        i++;
        q.push(a[i]);
        //cout<<"i="<<i<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值