A Knight's Journey

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 32470 Accepted: 11060

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
题意:骑士只能在棋盘上走“日”字,问是否能走遍整个棋盘
深度优先搜索
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>

using namespace std;

int dis[50][2],vis[50][50];
int dx[8]={-2,-2,-1,-1,1,1,2,2};
int dy[8]={-1,1,-2,2,-2,2,-1,1};
int p,q;

int dfs(int s,int e,int x,int y)
{
	if(s==e)
		return 1;//搜索成功,直接返回1
	for(int i=0;i<8;i++)//按字典序移动
	{
		int px=x+dx[i];
		int py=y+dy[i];
		if(px>=0&&px<q&&py>=0&&py<p&&!vis[px][py])//该点未被访问过,且该点在棋盘内
		{
			vis[px][py]=1;//将该点标记为已读
			if(dfs(s+1,e,px,py))
			{
				dis[s][0]=px;
				dis[s][1]=py;//将搜到的点的坐标存到dis数组中
				return 1;//搜索成功
			}
			vis[px][py]=0;//搜索不成功,将该点标记为未读
		}
	}
	return 0;//搜索不成功
}

int main()
{
	int n;
	scanf("%d",&n);
	int ans=1;
	while(n--)
	{
		//int p,q;
		scanf("%d%d",&p,&q);
		memset(vis,0,sizeof(vis));
		vis[0][0]=1;
		dis[0][0]=0;
		dis[0][1]=0;
		printf("Scenario #%d:\n",ans);
		if(dfs(1,p*q,0,0))//搜索成功,输出结果
		{
			for(int i=0;i<p*q;i++)
			{
				printf("%c%d",dis[i][0]+'A',dis[i][1]+1);
			}
		}
		else
		{
			printf("impossible");
		}
		printf("\n\n");
		ans++;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值