POJ 3126 Prime Path

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12111 Accepted: 6876

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

题意:给出两个四位数,每次只能改变一位数,且改变后的数依然是素数,求改变次数;可以直接遍历每位数,用队列保存每次改变后的数。需要注意的是千位不能为0,个位必须为奇数。

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <queue>

using namespace std;

int prime[20000];//开始数组开小了,一直超内存
int vis[20000];//标记该数是否被访问过

struct node
{
	int num;
	int sum;
};

queue<node>q;

void Prime()//找出1000到10000之间的所有素数
{
	for(int i=1000;i<=10000;i++)
	{
		int flag=0;
		for(int j=2;j<=sqrt(i);j++)
		{
			if(i%j==0)
			{
				flag=1;
				break;
			}
		}
		if(!flag)
		{
			prime[i]=1;
			//printf("%d ",i);
			//s++;
		}
	}
}

void bfs(int y)
{
	node t;
	while(!q.empty())
	{
		node a;
		a=q.front();
		q.pop();
		//cout<<a.num<<endl;
		if(a.num==y)
		{
			printf("%d\n",a.sum);
			return ;
		}
		for(int i=1;i<=9;i++)//千位,不能为0
		{
			int s=a.num%1000+i*1000;
			//cout<<s<<endl;
			if(s!=a.num&&prime[s]&&!vis[s])
			{
				//cout<<s<<endl;
				t.num=s;
				t.sum=a.sum+1;
				q.push(t);
				vis[s]=1;
			}
		}
		for(int i=0;i<=9;i++)//百位
		{
			int s=a.num/1000*1000+i*100+a.num%100;
			if(s!=a.num&&prime[s]&&!vis[s])
			{
				//cout<<s<<endl;
				t.num=s;
				t.sum=a.sum+1;
				q.push(t);
				vis[s]=1;
			}
		}
		for(int i=0;i<=9;i++)//十位
		{
			int s=a.num/100*100+i*10+a.num%10;
			if(s!=a.num&&prime[s]&&!vis[s])
			{
				//cout<<s<<endl;
				t.num=s;
				t.sum=a.sum+1;
				q.push(t);
				vis[s]=1;
			}
		}
		for(int i=1;i<=9;i=i+2)//个位,一定是奇数
		{
			int s=a.num/10*10+i;
			if(s!=a.num&&prime[s]&&!vis[s])
			{
				//cout<<s<<endl;
				t.num=s;
				t.sum=a.sum+1;
				q.push(t);
				vis[s]=1;
			}
		}
	}
	printf("Impossible\n");
	return ;
}

int main()
{
	memset(prime,0,sizeof(prime));
	Prime();
	int n,x,y;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&x,&y);
		//cout<<x<<y<<endl;
		//printf("%d\n",x);
		memset(vis,0,sizeof(vis));
		vis[x]=1;
		while(!q.empty())
		{
			q.pop();
		}
		node t;
		t.num=x;
		t.sum=0;
		//cout<<x<<endl;
		//cout<<t.num<<endl;
		q.push(t);
		//node a;
		//a=q.front();
		//cout<<a.num<<endl;
		bfs(y);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值