POJ 1258 Agri-Net

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 41919 Accepted: 17095

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

这道题很简单,模板题 。求让所有农场两两都能通行的最小权值,即最小生成树

Prim做法:

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <string.h>

using namespace std;

const int INF=0x3f3f3f3f;

int Map[110][110];//记录两点之间距离
int vis[110];//标记该点是否读过
int dis[110];

void Prim(int n)
{
    int ans=0;
    int Min;
    int pos;
    int k=0;
    vis[1]=1;
    for(int i=2; i<=n; i++)//找节点1到其他节点的距离
    {
        dis[i]=Map[1][i];
        //cout<<dis[i]<<endl;
    }
    for(int i=1; i<=n; i++)
    {
        Min=INF;
        for(int j=2; j<=n; j++)
        {
            if(!vis[j]&&Min>dis[j])//找该点最小权值的边并记录
            {
                pos=j;
                Min=dis[j];
                //cout<<Min<<endl;
            }
        }
        vis[pos]=1;
        ans+=Min;//加上最小权值Min
        k++;
        //cout<<ans<<endl;
        for(int j=2; j<=n; j++)
        {
            if(!vis[j]&&dis[j]>Map[pos][j])
            {
                dis[j]=Map[pos][j];
            }
        }
        if(k==n-1)
        {
            printf("%d\n",ans);
            return ;
        }
    }

}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(Map,INF,sizeof(Map));
        memset(dis,0,sizeof(dis));
        memset(vis,0,sizeof(vis));
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                scanf("%d",&Map[i][j]);
                //cout<<Map[i][j]<<" ";
            }
        }
        Prim(n);
    }
    return 0;
}

Krus做法:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

int bin[110];//使用并查集
int sum;
int n;

struct Edge
{
	int u;
	int v;
	int w;
}edge[111*110];

int cmp(Edge a,Edge b)
{
	return a.w<b.w;
}

int Find(int x)
{
	return x==bin[x]?x:Find(bin[x]);
}

void Krus()
{
	int ans=0;
	int k=0;
	sort(edge,edge+sum,cmp);
	for(int i=1;i<=n;i++)//注意对bin数组初始化
	{
		bin[i]=i;
	}
	for(int i=0;i<sum;i++)
	{
		int x=Find(edge[i].u);
		int y=Find(edge[i].v);
		if(x!=y)//x与y不相等,归入一棵树
		{
			bin[y]=x;
			ans+=edge[i].w;
			k++;
		}
		if(k==n-1)//找到的边数为点数减1,则找到了最小生成树
		{
			printf("%d\n",ans);
			return ;
		}
	}
}

int main()
{
	int x;
	while(scanf("%d",&n)!=EOF)
	{
		sum=0;
		memset(edge,0,sizeof(edge));
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				scanf("%d",&x);
				edge[sum].u=i;//将边放入edge数组,并记录起点、终点和权值
				edge[sum].v=j;
				edge[sum].w=x;
				sum++;
			}
		}
		Krus();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值