POJ 2253 Frogger

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27295 Accepted: 8871

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:青蛙Freddy想要去拜访青蛙Fiona,由于湖水很脏所以他决定跳着过去,但距离太远,他要借助湖中的石头,要求的是青蛙Freddy在此过程中所有路径中青蛙跳跃最大距离的最小值,假设青蛙Freddy从i到j,那么他有两种途径,i-j或i-k-j,因此找出i-k和k-j的最大值再和i-j的值比较取最小值,这样最后得到的就是青蛙跳跃最大距离的最小值

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>

using namespace std;

double dis[300][300];
int n;

struct node
{
    double x;//虽然题目说是两个整数,但不知道为什么用int型是不对的
    double y;
} point[300];//记录石头的坐标

double dist(node a,node b)//计算两块石头之间的距离
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

void Floyd()//弗洛伊德算法的变形
{
    for(int k=1; k<=n; k++)
    {
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                dis[i][j]=min(dis[i][j],max(dis[i][k],dis[k][j]));
            }
        }
    }
}

int main()
{
    //int n;
    //int x,y;
    int s=0;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
		s++;
        for(int i=1; i<=n; i++)
        {
            scanf("%lf%lf",&point[i].x,&point[i].y);
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                dis[i][j]=dist(point[i],point[j]);
            }
        }
        Floyd();
        printf("Scenario #%d\n",s);
        printf("Frog Distance = %.3lf\n\n",dis[1][2]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值