POJ 2392 Space Elevator

Space Elevator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8783 Accepted: 4173

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source

USACO 2005 March Gold

题意:一群牛要去太空,它们计划建造一种太空电梯--巨大的塔,现给出建造塔用的木块的高度,限制高度和数量,求塔的最大高度。

完全背包,但要先对木块的限制高度进行排序,以把较低的限制高度的木块尽量放在下面

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>

using namespace std;

int K;
int dp[40010];

struct node
{
	int h;
	int a;
	int c;
}block[500];

int cmp(node a,node b)
{
	return a.a<b.a;
}

void ZeroOnePack(int cost,int weight,int lim)
{
	for(int i=lim;i>=cost;i--)
	{
		dp[i]=max(dp[i],dp[i-cost]+weight);
	}
}

void CompletePack(int cost,int weight,int lim)
{
	for(int i=cost;i<=lim;i++)
	{
		dp[i]=max(dp[i],dp[i-cost]+weight);
	}
}

void MultiplePack(int cost,int weight,int num,int lim)
{
	if(cost*num>=lim)
	{
		CompletePack(cost,weight,lim);
	}
	else
	{
		int k=1;
		while(k<num)
		{
			ZeroOnePack(k*cost,k*weight,lim);
			num-=k;
			k*=2;
		}
		ZeroOnePack(num*cost,num*weight,lim);
	}
}

int main()
{
	scanf("%d",&K);
	for(int i=0;i<K;i++)
	{
		scanf("%d%d%d",&block[i].h,&block[i].a,&block[i].c);
	}
	memset(dp,0,sizeof(dp));
	sort(block,block+K,cmp);
	int Max=0;
	for(int i=0;i<K;i++)
	{
		MultiplePack(block[i].h,block[i].h,block[i].c,block[i].a);
	}
	for(int i=0;i<40010;i++)
	{
		Max=max(Max,dp[i]);
	}
	printf("%d\n",Max);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值