POJ - 2392 Space Elevator

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000).

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS:

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

题解:反正就是垒木块,最高垒多高,输入【这种木块的高度】【可以用这种木块的最高高度(限制高度就是你搭木块超过了这个高度 就不能再用这种木块了)】【这种木块的数目】

按限制高度排序,如果把大的放前面,后面小的就取不到了。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[40010];//记录高度
struct node
{
    int h,a,c;
}mp[500];
bool cmp(node x,node y)
{
    return x.a<y.a;
}
int main()
{
    int k;
    while(~scanf("%d",&k))
    {
        int i,j;
        memset(dp,0,sizeof(dp));
        for(i=0; i<k; i++)
            scanf("%d%d%d",&mp[i].h,&mp[i].a,&mp[i].c);
        sort(mp,mp+k,cmp);
        dp[0]=1;
        int ans=0,num[40010];//数目
        for(i=0; i<k; i++)
        {
            memset(num,0,sizeof(num));
            for(j=mp[i].h; j<=mp[i].a; j++)
                if(dp[j]==0&&dp[j-mp[i].h]&&num[j-mp[i].h]<mp[i].c)
                {
                    dp[j]=1;
                    num[j]=num[j-mp[i].h]+1;
                    if(ans<j)
                        ans=j;
                }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值