最小生成树

问题 D: 继续畅通工程

时间限制: 1 Sec  内存限制: 32 MB
提交: 59  解决: 37
[提交][状态][讨论版][命题人:外部导入]

题目描述

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。

输入

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

当N为0时输入结束。

输出

每个测试用例的输出占一行,输出全省畅通需要的最低成本。

样例输入

4
1 2 1 1
1 3 6 0
1 4 2 1
2 3 3 0
2 4 5 0
3 4 4 0
3
1 2 1 1
2 3 2 1
1 3 1 0
0

样例输出

3
0

 

如果已经修建公路说明它已经加入生成树中,把它的边权值设置为0

#include <iostream>
#include<algorithm>
#include<stdio.h>
#include<vector>
using namespace std;
class edge{
public:
    int u,v;//两条边
    int cost;//边之间的权值
    int zhuangtai;
};
edge thesetofedge[12000];
//vector<edge>thesetofedge;
bool cmp(edge a,edge b){
return a.cost<b.cost;}
int father[110];//最多110个顶点
int findfather(int x){
while(x!=father[x])
    x=father[x];
return x;
}
void init(int n){
for(int i=1;i<=n;i++)
    father[i]=i;
}
int kruskal(int n,int m){
int sum=0;
int numedge=0;//numedge为当前生成树的边数目
//初始化并查集数组
for(int i=1;i<=n;i++)
    father[i]=i;
sort(thesetofedge+1,thesetofedge+1+m,cmp);//安权值排序.
//for(int i=1;i<=m;i++)
  //  cout<<thesetofedge[i].cost<<endl;
for(int i=1;i<=m;i++){//遍历所有的边
    int fatheru=findfather(thesetofedge[i].u);
    int fatherv=findfather(thesetofedge[i].v);
    if(fatheru!=fatherv){
        father[fatheru]=fatherv;
        sum+=thesetofedge[i].cost;
        numedge++;
        if(numedge==n-1)
            break;
    }

}
//cout<<numedge<<"sf"<<endl;
    if(numedge!=n-1)
        return -1;
    else
        return sum;
}//n是点数,m的边数返回最小生成树的权值
int main()
{   int u,v,cost;
int bianshu=0;
    int n;
    int m;
    int sum;
    int a,b,c,d;
    while((cin>>n)&&n!=0){
      for(int i=1;i<=n*(n-1)/2;i++){
         cin>>a>>b>>c>>d;
         if(d==1)
            c=0;
         thesetofedge[i].u=a;
         thesetofedge[i].v=b;
         thesetofedge[i].cost=c;
         thesetofedge[i].zhuangtai=d;
      }
    // for(int i=1;i<=n*(n-1)/2;i++)
        //cout<<thesetofedge[i].u<<" "<<thesetofedge[i].v<<" "<<thesetofedge[i].cost<<endl;
       // cout<<bianshu<<endl;
        sum=kruskal(n,n*(n-1)/2);
        cout<<sum<<endl;

    }
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值