poj 2823 Sliding Window 单调队列

点击打开链接 题目链接

Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 40565 Accepted: 11982
Case Time Limit: 5000MS

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  knumbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

用一个长度为k的窗在整数数列上移动,求窗里面所包含的数的最小值最大值。


单调队列定义:

a)从队头到队尾,元素在我们所关注的指标下是递减的(严格递减,而不是非递增),比如查询如果每次问的是窗口内的最小值,那么队列中元素从左至右就应该递增,如果每次问的是窗口内的最大值,则应该递减,依此类推。这是为了保证每次查询只需要取队头元素。

b)从队头到队尾,元素对应的时刻(此题中是该元素在数列a中的下标)是递增的,但不要求连续,这是为了保证最左面的元素总是最先过期,且每当有新元素来临的时候一定是插入队尾。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int que[1111111],num[1111111],maxn[1111111],minn[1111111],index[1111111];
int n,k;
void getmin()
{
    int fr=1,ed=0,i;
    for(i=0;i<k-1;i++)
    {
        while(fr<=ed&&que[ed]>=num[i])
            ed--;
        que[++ed]=num[i];
        index[ed]=i;
    }
    for(;i<n;i++)
    {
        while(fr<=ed&&que[ed]>=num[i])
            ed--;
        que[++ed]=num[i];
        index[ed]=i;
        while(index[fr]<i-k+1)
        {
            fr++;
        }
        minn[i-k+1]=que[fr];
    }
}
void getmax()
{
    int fr=1,ed=0,i;
    for(i=0;i<k-1;i++)
    {
        while(fr<=ed&&que[ed]<=num[i])
            ed--;
        que[++ed]=num[i];
        index[ed]=i;
    }
    for(;i<n;i++)
    {
        while(fr<=ed&&que[ed]<=num[i])
            ed--;
        que[++ed]=num[i];
        index[ed]=i;
        while(index[fr]<i-k+1)
        {
            fr++;
        }
        maxn[i-k+1]=que[fr];
    }
}
int main()
{
    //freopen("acm.txt","r",stdin);
    scanf("%d %d",&n,&k);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&num[i]);
    }
    getmin();
    getmax();
    for(int i=0;i<n-k+1;i++)
    {
        if(i<n-k)
            printf("%d ",minn[i]);
        else
            printf("%d\n",minn[i]);
    }
    for(int i=0;i<n-k+1;i++)
    {
        if(i<n-k)
            printf("%d ",maxn[i]);
        else
            printf("%d\n",maxn[i]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值