PAT 1074. Reversing Linked List (25)(链表反转)

官网

1074. Reversing Linked List (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

解题思路

  • 1.是每k次反转一下,不是前k次反转就行了,我看错了大半年别学我。
  • 2.注意k=0,1,链表的长度(不一定为n),以及k>链表的长度这几种情况就可以了。

AC代码

#include<string>
#include<iostream>
#include<map>
#include<cstdio>
#include<vector>
#include<deque>
#include<algorithm>
#include<math.h>
using namespace std;
//00100 6 6
//00000 4 99999
//00100 1 12309
//68237 6 -1
//33218 3 00000
//99999 5 68237
//12309 2 33218
int value[100000],nx[100000];
int main(int argc, char *argv[])
{
    int firstAddre,n,k;
    cin >> firstAddre >> n >> k;
    int tem;
    for (int i = 0; i < n; ++i) {
        cin >> tem;
        cin >> value[tem]>>nx[tem];
    }
    int now = firstAddre;
    //储存
    vector<int> keep;
    while (now!=-1) {
        keep.push_back(now);
        now = nx[now];
    }

    int bot,up ;
    int N = 0;
    if (k!=0) {
        N = keep.size()/k;
    }
    //每k次反转
    for (int j = 0; j < N; ++j) {
            for (int i = 1; i <= k/2; ++i) {
                up = i-1+k*j;
                bot = k-i+k*j;
                tem = keep[up];
                keep[up] = keep[bot];
                keep[bot] = tem;
            }
    }
    //输出
    for (int i = 0; i < (int)keep.size()-1; ++i) {
        tem = keep[i];
        printf("%05d %d %05d\n",tem,value[tem],keep[i+1]);
    }
    printf("%05d %d -1\n",keep.back(),value[keep.back()]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值