HDU - 1394 Minimum Inversion Number(线段树 + 求最小逆序数)

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25773    Accepted Submission(s): 15181


 

Problem Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

 

 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

 

 

Output

For each case, output the minimum inversion number on a single line.

 

 

Sample Input

 

10

1 3 6 9 0 8 5 7 4 2

 

 

Sample Output

 

16


大致题意:给你一个序列 求这序列中最小逆序数 (所有数都是从0 到 n - 1 并且不会出现重复的数)

解题思路: 先找出这个序列的逆序数个数  对于线段树来说 更新一个数a就让线段树[a, a]区间值为1 代表有这个数在序列里了

对与查找有多少个比a大的数就查找(a, n)这个区间的值  这个值就是

所有比a大的数 对于如何找最小逆序数   公式为: 当前序列逆序数个数 - 所有比移动值小的数 + 总数 - 

所有比移动值小的数 - 1(该数本身);


#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
#include <algorithm>
#define lson rt << 1
#define rson rt << 1 | 1
const int INF = 0x3f3f3f3f;
const int MAXN = 5e3 + 10;
int data[MAXN];
int st[MAXN << 2];
using namespace std;

void PushUp(int rt)
{
    st[rt] = st[lson] + st[rson];
    return ;
}

void Built(int l, int r, int rt)//建树  将所有值初始化为0
{
    st[rt] = 0;
    if (l == r)
        return ;
    int m = (l + r) >> 1;
    Built(l, m, lson);
    Built(m + 1, r, rson);
    return ;
}

int Query(int L, int R, int l, int r, int rt)//查询
{
    if (L <= l && r <= R)
        return st[rt];
    int ret = 0;
    int m = (l + r) >> 1;
    if (L <= m)
        ret += Query(L, R, l, m, lson);
    if (m < R)
        ret += Query(L, R, m + 1, r, rson);
    return ret;
}

void Update(int w, int l, int r, int rt)//更新  代表w加入序列
{
    if (l == r)
    {
        st[rt] = 1;
        return ;
    }
    int m = (l + r) >> 1;
    if (w <= m)
        Update(w, l, m, lson);
    else
        Update(w, m + 1, r, rson);
    PushUp(rt);
    return ;
}

int main()
{
    int n;
    while (cin >> n)
    {
        Built(0, n - 1, 1);//因为题目从0开始 我选择从0开始建树  也可以从一开始 不过后面data[i]的值必须加1 查询区间从1 - n
        int sum = 0;//当前序列逆序数个数
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &data[i]);
            sum += Query(data[i], n - 1, 0, n - 1, 1);//查询这位数的逆序数个数  也就是查询比这个数大的区间
            Update(data[i], 0, n - 1, 1);//更新
        }
        int ans = sum;
        for (int i = 0; i < n; i++)//计算最小逆序数个数
        {
            sum = sum - data[i] + n - 1 - data[i];
            ans = min(sum, ans);
        }
        printf("%d\n", ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值