hdu1394 Minimum Inversion Number 逆序数、最小逆序数

Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
题意是,给一串数字,每次可以将第一个数移到最后,然后问你在移动过程中,逆序数最小是多少。

直接暴力显然超时,在输入的时候可以用线段树维护当前在某个区间内有多少个数已经出现,例如(本题样例):在输入“0”的时候可以查询线段树上0-9有多少个数已经出现,显然出现的数个数”就是一位上的逆序数“,即在输入a时,查询a-(n-1)有多少个数出现了,然后将这些单个的逆序数加起来就是这一串数字的逆序数;在每次查询之后需要将线段树更新,此时a已经出现了,需要将对应的区间更新。

#include<bits/stdc++.h>
using namespace std;
#define maxn 5000
typedef long long ll;

struct node
{
    int l,r,cnt;//在l-r中已经有cnt个数出现
}tree[maxn*4+10];
int a[maxn+10];
void build(int l,int r,int node)
{
    tree[node].l=l;
    tree[node].r=r;
    if(l==r)
    {
        tree[node].cnt=0;
        return ;
    }
    int mid=(l+r)>>1;
    build(l,mid,node<<1);
    build(mid+1,r,node<<1|1);
    tree[node].cnt=tree[node<<1].cnt+tree[node<<1|1].cnt;
}
int cal(int l,int r,int node)
{
    if(tree[node].l==l&&tree[node].r==r)
    {
       return tree[node].cnt;
    }

    int mid=(tree[node].r+tree[node].l)>>1;
    int ans=0;
    if(r<=mid)
        return cal(l,r,node<<1);
    else if(l>mid)
        return cal(l,r,node<<1|1);
    return cal(l,mid,node<<1)+cal(mid+1,r,node<<1|1);
}
void update(int val,int node)
{
    if(tree[node].l==tree[node].r&&tree[node].l==val)
    {
        tree[node].cnt=1;
        return ;
    }
    int mid=(tree[node].l+tree[node].r)>>1;
    if(val<=mid)
        update(val,node<<1);
    else update(val,node<<1|1);
    tree[node].cnt=tree[node<<1].cnt+tree[node<<1|1].cnt;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        build(1,n,1);
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            ans+=cal(a[i]+1,n,1);
            update(a[i]+1,1);
             //for(int j=1;j<=n*4;j++)
           // printf("%d %d %d %d\n",j,tree[j].l,tree[j].r,tree[j].cnt);

        }
        int res=ans;
        for(int i=1;i<=n;i++)
        {
            res=res-a[i]+n-a[i]-1;
            ans=min(ans,res);

        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值