Codevs_P2859 丑数统计(堆)

4 篇文章 0 订阅

题目描述 Description
对于自然数n,求前n个素因子仅有2,3或5的数,并从小到大输出到文件中。如N=10,答案为:2 3 4 5 6 8 9 10 12 15

输入描述 Input Description
一个正整数n(n<10000)

输出描述 Output Description
n个满足条件的正整数,以空格分开。

样例输入 Sample Input
10

样例输出 Sample Output
2 3 4 5 6 8 9 10 12 15

数据范围及提示 Data Size & Hint

#include<cstdio>
#include<map>
#include<algorithm>
#include<iostream>
using namespace std;
#define N 5843
long long size,heap[N*N];
long long n,ans[N+8];
map<long long,bool> p;
long long top(){
    int now,next;
    long long res=heap[1];
    now=1;heap[1]=heap[size--];
    while(now*2<=size){
        next=now*2;
        if(next+1<=size&&heap[next+1]<heap[next]) next++;
        if(heap[now]<heap[next]) break;
        swap(heap[now],heap[next]);
        now=next;
    }
    return res;
}
void pop(long long x){
    if(p[x]) return;
    else p[x]=true;
    int now,next;
    heap[++size]=x;
    now=size;
    while(now>1){
        next=now/2;
        if(heap[next]<heap[now]) break;
        else swap(heap[next],heap[now]);
        now=next;
    }
}
void work(){
    size=n=ans[1]=heap[1]=1;
    while(n<N+2){
        pop(ans[n]*2);
        pop(ans[n]*3);
        pop(ans[n]*5);
        ans[++n]=top();
        if(ans[n-1]==ans[n]) n--;
    }
}
int main(){
    work();
    scanf("%d",&n);
    for(int i=2;i<=n+1;i++) printf("%lld ",ans[i]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值