Phone List

题目链接

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11757    Accepted Submission(s): 3995


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 数组代码:
/*
Author: 2486
Memory: 2764 KB		Time: 157 MS
Language: G++		Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <vector>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
const int MAXN = 10000000 + 5;


struct node {
    int v,next[10];
    void init() {
        v = -1;//表示不是字符串的结尾
        memset(next, -1, sizeof(next));
    }
} L[MAXN];

int tot, T, n;
bool flag;


void add(char a[], int len) {
    int now = 0;
    for(int i = 0; i < len; i ++) {
        int tmp = a[i] - '0';
        int next = L[now].next[tmp];
        if(next == -1) {//增加尾部字符
            next = ++ tot;
            L[next].init();
            L[now].next[tmp] = tot;
        }
        if(L[next].v == 0)flag = true;
        now = next;
    }
    L[now].v = 0;//表示此时是字符串的结尾
    for(int i = 0; i < 10; i ++) {
        if(L[now].next[i] != -1)flag = true;//检查是否为其他串的子串
    }
}


int main() {
    char op[15];
    scanf("%d", &T);
    while(T --) {
        scanf("%d", &n);
        tot = 0;
        flag = false;
        L[0].init();
        for(int i = 0; i < n; i ++) {
            scanf("%s", op);
            if(!flag)add(op,strlen(op));
        }
        printf("%s\n",flag ? "NO" : "YES");
    }
    return 0;
}



指针代码:

#include <iostream>
#include <string>
#include <cstdlib>
#include <cstring>
#include <cstdio>
char str[12];
const int MAX=10;
using namespace std;
struct Tire{
    Tire *next[MAX];
    int v;
    int vv;
};
Tire *root;
void creatTire(char *str){
int len=strlen(str);
Tire *p=root,*q;
for(int i=0;i<len;i++){
int id=str[i]-'0';
if(p->next[id]==NULL){
    q=(Tire *)malloc(sizeof(Tire));
    q->v=1;
    for(int j=0;j<MAX;j++){
        q->next[j]=NULL;
    }
    q->vv=0;
    p->next[id]=q;
    p=q;
}
else{
    p->next[id]->v++;
    p=p->next[id];
}
}
p->vv=-1;
}
bool findTire(char *str){
int len=strlen(str);
Tire *q=root;
for(int i=0;i<len;i++){
    int id=str[i]-'0';
    q=q->next[id];
    if(q==NULL){
        return false;
    }
    if(q->vv==-1){
            if(q->v>1){
                return true;
            }else{
            return false;
            }


    }
}
return true;
}
void delTire(Tire *to){
int i;
if(to==NULL){
    return ;
}
for(i=0;i<MAX;i++){
     delTire(to->next[i]);
}
free(to);
return;
}
int main(){
int t,n;bool success=false;
//freopen("D://imput.txt","r",stdin);
cin>>t;
while(t--){
    success=false;
    root=(Tire *)malloc(sizeof(Tire));
    for(int i=0;i<MAX;i++){
        root->next[i]=NULL;
        root->vv=0;
        root->v=0;
    }
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>str;
        creatTire(str);
    if(findTire(str)){
        success=true;
    }
    }
    if(!success){
        cout<<"YES"<<endl;
    }else{
    cout<<"NO"<<endl;
    }
    delTire(root);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值