HDU - 1875畅通工程再续-最小生成树

HDU - 1875
Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

 Status

Description

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
 

Input

输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。 
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。 
 

Output

每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
 

Sample Input

        
        
2 2 10 10 20 20 3 1 1 2 2 1000 1000
 

Sample Output

        
        
1414.2 oh!
 将所有岛之间的距离算出来然后运用最小生成树即可求出
/*
Author: 2486
Memory: 1556 KB		Time: 46 MS
Language: G++		Result: Accepted
*/
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int N=10005;
const double eps=1e-8;
struct edge {
    int v,u;
    double cost;
    friend bool operator <(const edge &a,const edge &b) {
        return a.cost<b.cost;
    }
} es[N];
struct island {
    int x,y;
    double cost;
} IsLand[N];
int par[N],ranks[N],n,islandnumber;
void init(int sizes) {
    for(int i=0; i<=sizes; i++) {
        par[i]=i;
        ranks[i]=1;
    }
}
int find(int x) {
    return par[x]==x?x:par[x]=find(par[x]);
}
bool same(int x,int y) {
    return find(x)==find(y);
}
void unite(int x,int y) {
    x=find(x);
    y=find(y);
    if(x==y)return ;
    if(ranks[x]>ranks[y]) {
        par[y]=x;
    } else {
        par[x]=y;
        if(ranks[x]==ranks[y])ranks[x]++;
    }
}
void kruskal(int sizes) {
    sort(es,es+sizes);
    init(sizes);
    double res=0;
    int cur=0;
    for(int i=0; i<sizes; i++) {
        edge e=es[i];
        if(!same(e.u,e.v)) {
            unite(e.u,e.v);
            res+=e.cost;
            cur++;
        }
    }
    if(cur==islandnumber-1) {//n个岛屿有n-1条边,所以如果没有n-1条边形成的话,则表明无法连通所有的岛屿
        printf("%.1lf\n",res);
    } else {
        printf("oh!\n");
    }
}
int main() {
    double temp;
    scanf("%d",&n);
    while(n--) {
        int cur=0;
        scanf("%d",&islandnumber);
        for(int i=0; i<islandnumber; i++) {
            scanf("%d%d",&IsLand[i].x,&IsLand[i].y);
        }
        for(int i=0; i<islandnumber; i++) {
            for(int j=0; j<i; j++) {
                //算出每一个岛屿之间的距离
                temp=sqrt(double((IsLand[i].x-IsLand[j].x)*(IsLand[i].x-IsLand[j].x)+(IsLand[i].y-IsLand[j].y)*(IsLand[i].y-IsLand[j].y)));
                if(temp<10||1000<temp)continue;
                es[cur].v=i;
                es[cur].u=j;
                es[cur++].cost=temp*100.0;
            }
        }
        kruskal(cur);
    }
    return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值