HDU - 1677Nested Dolls最长上升子序列变式

HDU - 1677
Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

 Status

Description

Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements? 
 

Input

On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i. 
 

Output

For each test case there should be one line of output containing the minimum number of nested dolls possible. 
 

Sample Input

        
        
4 3 20 30 40 50 30 40 4 20 30 10 10 30 20 40 50 3 10 30 20 20 30 10 4 10 10 20 30 40 50 39 51
 

Sample Output

        
        
1 2 3 2
大概意思与最小拦截系统类似
 第一种方法,自己写二分函数
/*
Problem : 1677 ( Nested Dolls )     Judge Status : Accepted
RunId : 14351565    Language : G++    Author : 24862486
*/
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 20000 + 5;
const int INF=0x3f3f3f3f;
struct point {
    int h, w;
    point(int w ,int h) : w(w), h(h) {}
    point() {}
} ps[maxn];
int dp[maxn], t, m;
bool cmp(const point &a,const point &b) {
    if(a.w == b.w) return a.h < b.h;
    return a.w > b.w;
}
int solve() {
    memset(dp,0,sizeof(dp));
    int top = 0, maxx = -1;
    dp[top] = -1;
    for(int i = 1; i <= m; i ++) {
        if(ps[i].h >= dp[top]) {
            dp[++ top] = ps[i].h;//其中dp[1]--dp[top]一定是不下降子序列,因为每一次的新系统的生成,表示大于他的值
        } else {
            int l = 0,r = top;//(0,top]
            while(r - l > 1) {
                int mid = (l + r) >> 1;
                if(ps[i].h < dp[mid]) {//是不能够相等,相等则依旧取不到
                    r = mid;
                } else
                    l = mid;
            }
            dp[r] = ps[i].h;
        }
    }
    return top;
}
int main() {
    //freopen("D://imput.txt", "r", stdin);
    scanf("%d", &t);
    while(t --) {
        scanf("%d", &m);
        for(int i = 1; i <= m; i ++) {
            scanf("%d%d", &ps[i].w, &ps[i].h);
        }
        sort(ps + 1,ps + m + 1,cmp);
        printf("%d\n",solve());
    }
    return 0;
}

第二种,运用upper_bound以及lower_bound函数
/*
Problem : 1677 ( Nested Dolls )     Judge Status : Accepted
RunId : 14351713    Language : G++    Author : 24862486
*/
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 20000 + 5;
const int INF=0x3f3f3f3f;
struct point {
    int h, w;
    point(int w ,int h) : w(w), h(h) {}
    point() {}
    bool operator < (const point &object)const {
        return h < object.h;
    }
} ps[maxn],dp[maxn];
bool cmp(const point &a,const point &b) {
    if(a.w == b.w) return a.h < b.h;
    return a.w > b.w;
}
int main() {
    //freopen("D://imput.txt", "r", stdin);
    int t, m;
    scanf("%d", &t);
    while(t --) {
        scanf("%d", &m);
        for(int i = 0; i < m; i ++) {
            scanf("%d%d", &ps[i].w, &ps[i].h);
        }
        sort(ps,ps + m,cmp);
        for(int i = 0; i < m ; i ++) {
            dp[i].h = INF;
            dp[i].w = INF;
        }
        for(int i = 0; i < m ; i ++) {
            *upper_bound(dp,dp + m, ps[i]) = ps[i];//不是lower_bound()原因是不能够相等
        }
        printf("%d\n", lower_bound(dp, dp + m, point(INF,INF)) - dp);
    }
    return 0;
}


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值