poj 1836 Alignment -dp(合唱队形变式)-最长上升子序列+最长下降子序列

Alignment

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
• 2 <= n <= 1000
• the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4


题意

士兵拍成一行,让最少的士兵出列,出列后的队伍使得每个士兵都能至少能看到最左或最右边上的士兵(中间某个人能看到最边上的士兵的条件是该士兵的身高一定强大于他某一边所有人的身高)

解题思路

一开始理解错题

题目和合唱队形很像,但是又有区别。因为只要能看到一边就可以了,所以允许队形是梯形(上底只有两个人)。这个特殊处理

通过这道题我深刻的认识到了 从左边开始做最长上升子序列和从右边开始做最长下降子序列的含义是不一样的

从左边开始做最长上升子序列 得到的是a【i】左边比a【i】小的数的个数。

从右边开始做最长下降子序列 得到的是a[i] 右边比 a[i]大的个数。

含义是不一样的!



代码

#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;

const int N = 1002;

int up[N], down[N];
double h[N];

int main()
{
     int n, i, j;

	 scanf("%d", &n);
     for(i = 1; i <= n; i++)
		 scanf("%lf", &h[i]);

	 for(i = 1; i <= n; i++)//左边比h[i]小的的个数
	 {
		 up[i] = 1;
		 for(j = 1; j <= i-1; j++)
         {
             if(h[i] > h[j])
             {
				 if(up[i] <= up[j])
					 up[i] = up[j] + 1;
			 }
         }


	 }
	 for(i = n; i >= 1; i--)//i右边比h[i]小的的个数
	 {
		 down[i] = 1;
		 for(j = i+1; j <= n; j++)
        {
            if(h[j] < h[i])
            {
				 if(down[i] <= down[j])
				      down[i] = down[j] + 1;
			 }
        }

	 }

	 int tmp = 0;
	 for(i = 1; i < n; i++)//这样就能把h[i]==h[j]的情况考虑进去了
		 for(j = i+1;  j <= n; j++)
			 if(up[i] + down[j] > tmp)
				 tmp = up[i] + down[j];
	 printf("%d\n", n - tmp);
	 return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值