FZU 2140 Forever 0.5(计算几何)

A - Forever 0.5
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions:

1. The distance between any two points is no greater than 1.0.

2. The distance between any point and the origin (0,0) is no greater than 1.0.

3. There are exactly N pairs of the points that their distance is exactly 1.0.

4. The area of the convex hull constituted by these N points is no less than 0.5.

5. The area of the convex hull constituted by these N points is no greater than 0.75.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each contains an integer N described above.

1 <= T <= 100, 1 <= N <= 100

Output

For each case, output “Yes” if this kind of set of points exists, then output N lines described these N points with its coordinate. Make true that each coordinate of your output should be a real number with AT MOST 6 digits after decimal point.

Your answer will be accepted if your absolute error for each number is no more than 10-4.

Otherwise just output “No”.

See the sample input and output for more details.

Sample Input

3
2
3
5

Sample Output

No
No
Yes
0.000000 0.525731
-0.500000 0.162460
-0.309017 -0.425325
0.309017 -0.425325
0.500000 0.162460

Hint

This problem is special judge.


题意:让你找n个点,这些点满足下面的条件

1.任意两点之间的距离要不大于1

2.任意一点到原点的距离不大于1

3.有且只有n对点的距离等于1

4.这些点构成的凸包面积不小于0.5

5.这些点构成的凸包面积不大于0.75

求解最终是否存在这么n个点,如果存在输出"Yes"和这n个点的坐标,否则输出"No"

分析题目:

只要是小于4个点一定输出No

然后由于题目是特判,所以只要找出满足条件的就可以了,

所以我们可以构建下面的四边形


前四个点就是O, A, C, B,然后剩下的点在AC这条弧上面找就可以了

其中OA = OC = CA = CB = 1,CB垂直AO

#include <queue>
#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

//#pragma comment(linker, "/STACK:1024000000,1024000000")

#define FIN             freopen("input.txt","r",stdin)
#define FOUT            freopen("output.txt","w",stdout)
#define fst             first
#define snd             second

typedef __int64  LL;
typedef pair<int, int> PII;

const int MAXN = 1e2 + 5;
int T, n;
double X[MAXN], Y[MAXN];
int main() {
#ifndef ONLINE_JUDGE
//    FIN;
//    FOUT;
#endif // ONLINE_JUDGE
    scanf ("%d", &T);
    while (T --) {
        scanf ("%d", &n);
        if (n < 4) {
            printf ("No\n");
            continue;
        }
        printf ("Yes\n");
        X[0] = 0, Y[0] = 0;
        X[1] = 1, Y[1] = 0;
        X[2] = 0.5, Y[2] = sqrt (3.0) / 2.;
        X[3] = 0.5, Y[3] = Y[2] - 1;
        double k = 2e-3;
        for (int i = 4; i < n; i ++) {
            Y[i] = i * k;
            X[i]  = sqrt (1 - Y[i] * Y[i]);
        }
        for (int i = 0; i < n; i ++) {
            printf ("%.6f %.6f\n", X[i], Y[i]);
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值