fzu-2140 Forever 0.5

题目:

Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions:

1. The distance between any two points is no greater than 1.0.

2. The distance between any point and the origin (0,0) is no greater than 1.0.

3. There are exactly N pairs of the points that their distance is exactly 1.0.

4. The area of the convex hull constituted by these N points is no less than 0.5.

5. The area of the convex hull constituted by these N points is no greater than 0.75.


Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each contains an integer N described above.

1 <= T <= 100, 1 <= N <= 100

Output

For each case, output “Yes” if this kind of set of points exists, then output N lines described these N points with its coordinate. Make true that each coordinate of your output should be a real number with AT MOST 6 digits after decimal point.

Your answer will be accepted if your absolute error for each number is no more than 10-4.

Otherwise just output “No”.

See the sample input and output for more details.

Sample Input
3
2
3
5
Sample Output
No
No
Yes
0.000000 0.525731
-0.500000 0.162460
-0.309017 -0.425325
0.309017 -0.425325
0.500000 0.162460
Hint

This problem is special judge.

题意:判断n个点能不能组成满足题目条件的n边形

思路:首先,任意两点距离不超过1.0,任一点到原点(0,0)距离不超过1.0,易想到单位圆。然后有n对点距离是1.0,且n边形面积不少于0.5,不多于0.75。如果n=1或2的话,不能组成图形,输出No;n=3的话,三条边相等且为1.0,则这个三角形为等边三角形,面积为0.43不满足条件,输出No;n=4的话在单位圆里作出四边形ABCD,易得面积为0.5,满足条件;n>4的话,把多出的点放在扇形ABC的弧BC上,扇形ABC的面积约为0.52,加上三角形ADB的面积不会超过0.75,满足条件,所以后面多出的点皆可放在弧BC上,每次减少C的纵坐标0.001即可,通过x^2+y^2=1可得x。

123

code:

#include<stdio.h>
#include<math.h>
int main(){
        int t,n;
        scanf("%d",&t);
        while(t--){
                scanf("%d",&n);
                if(n<4) puts("No");
                else{
                        puts("Yes");
                        double y=sqrt(3)/2;
                        puts("0.000000 0.000000");
                        puts("1.000000 0.000000");
                        printf("0.500000 %f\n",y);
                        printf("0.500000 -%f\n",1-y);
                        for(int i=5;i<=n;i++){
                                y-=0.001;
                                printf("%f %f\n",sqrt(1-y*y),y);
                        }
                }
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值