UVA - 227 Puzzle

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

A children's puzzle that was popular 30 years ago consisted of a 5x5 frame which contained 24 small squares of equal size. A unique letter of the alphabet was printed on each small square. Since there were only 24 squares within the frame, the frame also contained an empty position which was the same size as a small square. A square could be moved into that empty position if it were immediately to the right, to the left, above, or below the empty position. The object of the puzzle was to slide squares into the empty position so that the frame displayed the letters in alphabetical order.

The illustration below represents a puzzle in its original configuration and in its configuration after the following sequence of 6 moves:

 1) 		 The square above the empty position moves.

2) The square to the right of the empty position moves.

3) The square to the right of the empty position moves.

4) The square below the empty position moves.

5) The square below the empty position moves.

6) The square to the left of the empty position moves.

Write a program to display resulting frames given their initial configurations and sequences of moves.

Input

Input for your program consists of several puzzles. Each is described by its initial configuration and the sequence of moves on the puzzle. The first 5 lines of each puzzle description are the starting configuration. Subsequent lines give the sequence of moves.

The first line of the frame display corresponds to the top line of squares in the puzzle. The other lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.

The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square moves into the empty position. A denotes that the square above the empty position moves; B denotes that the square below the empty position moves; L denotes that the square to the left of the empty position moves; R denotes that the square to the right of the empty position moves. It is possible that there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move occurs, the puzzle is considered to have no final configuration. This sequence of moves may be spread over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.

Output

Output for each puzzle begins with an appropriately labeled number (Puzzle #1Puzzle #2, etc.). If the puzzle has no final configuration, then a message to that effect should follow. Otherwise that final configuration should be displayed.

Format each line for a final configuration so that there is a single blank character between two adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior position, then it will appear as a sequence of 3 blanks - one to separate it from the square to the left, one for the empty position itself, and one to separate it from the square to the right.

Separate output from different puzzle records by one blank line.

Note: The first record of the sample input corresponds to the puzzle illustrated above.

Sample Input

TRGSJ
XDOKI
M VLN
WPABE
UQHCF
ARRBBL0
ABCDE
FGHIJ
KLMNO
PQRS 
TUVWX
AAA
LLLL0
ABCDE
FGHIJ
KLMNO
PQRS 
TUVWX
AAAAABBRRRLL0
Z

Sample Output

Puzzle #1:
T R G S J
X O K L I
M D V B N
W P   A E
U Q H C F

Puzzle #2:
  A B C D
F G H I E
K L M N J
P Q R S O
T U V W X

Puzzle #3:
This puzzle has no final configuration.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;

char s[5][10];
int loc_x, loc_y;
bool illeg;

bool getPuz()
{
	for (int i = 0; i < 5; i++)
	{
		gets(s[i]);
		if (i == 0 && strcmp(s[i], "Z") == 0)
			return false;
	}
	return true;
}

bool Illeg(int a, int b)
{
	if (a<0 || a>4 || b<0 || b>4)
		return true;
	return false;
}

bool Move_A()
{
	if (Illeg(loc_x - 1, loc_y)) return false;
	s[loc_x][loc_y] = s[loc_x - 1][loc_y];
	s[loc_x - 1][loc_y] = ' ';
	loc_x--;
	return true;
}

bool Move_B()
{
	if (Illeg(loc_x + 1, loc_y)) return false;
	s[loc_x][loc_y] = s[loc_x + 1][loc_y];
	s[loc_x + 1][loc_y] = ' ';
	loc_x++;
	return true;
}

bool Move_L()
{
	if (Illeg(loc_x, loc_y-1)) return false;
	s[loc_x][loc_y] = s[loc_x][loc_y - 1];
	s[loc_x][loc_y - 1] = ' ';
	loc_y--;
	return true;
}

bool Move_R()
{
	if (Illeg(loc_x, loc_y+1)) return false;
	s[loc_x][loc_y] = s[loc_x][loc_y + 1];
	s[loc_x][loc_y + 1] = ' ';
	loc_y++;
	return true;
}

int main()
{
	int cas = 0;
	int first = 1;
	while (getPuz())
	{
		illeg = 0;
		for (int i = 0; i < 5; i++)
		for (int j = 0; j < 5; j++)
		{
			if (s[i][j] == ' ')
			{
				loc_x = i;
				loc_y = j;
				break;
			}
		}

		char op[100];
		int isend = 0;
		while (!isend)
		{
			cin >> op;
			for (int i = 0; i < strlen(op); i++)
			{
				if (op[i] == '0')
				{
					isend = 1; break;
				}
				bool res=1;
				switch (op[i])
				{
				case 'A':res=Move_A(); break;
				case 'B':res=Move_B(); break;
				case 'L':res=Move_L(); break;
				case 'R':res=Move_R(); break;
				}
				if (res == false) illeg = true;
			}
		}
		
		if (first) first=0;
		else cout << endl;
		printf("Puzzle #%d:\n", ++cas);
		if (illeg == true) cout << "This puzzle has no final configuration." << endl;
		else 
		for (int i = 0; i < 5; i++)
		{
			cout << s[i][0] << " " << s[i][1] << " " << s[i][2] << " " << s[i][3] << " " << s[i][4] << endl;
		}
		gets(s[0]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
vue-puzzle是一个Vue.js的人机验证组件,它可以用于在前端实现拼图验证码功能。 该组件可以用于替代第三方SDK的拼图验证,避免了引入SDK和后台配合的麻烦。你只需要通过npm安装vue-puzzle-vcode即可开始使用。 使用vue-puzzle-vcode时,你需要在代码中引入Vcode组件并使用它来展示验证模态框。你可以设置show属性来控制模态框的显示与隐藏,通过onSuccess事件来处理用户通过验证后的逻辑,通过onClose事件来处理关闭模态框的逻辑。 在示例中,当用户点击登录按钮时,会触发onSubmit方法,使验证码模态框显示出来。当用户通过验证后,会触发onSuccess方法,你需要在该方法中手动隐藏模态框。当用户点击遮罩层时,会触发onClose方法,你需要在该方法中关闭模态框。 除了以上提到的参数外,vue-puzzle还提供了其他可配置的参数,你可以根据需求进行设置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [Vue拼图验证组件使用教程](https://blog.csdn.net/weixin_40121676/article/details/102895804)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* *3* [vue 使用vue-puzzle-vcode拼图验证纯前端实现](https://blog.csdn.net/qq_37816525/article/details/102560656)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

这波lucio来全学了

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值