UVA424高精度加法

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of
powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
“This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.”
(Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky
apartments on Third Street.)
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInte-
ger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no
VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.
Output
Your program should output the sum of the VeryLongIntegers given in the input.
Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
Sample Output
370370367037037036703703703670

解题:大数相加,倒序输入数组再逐位计算,再倒序输出。注意输入数据中,VeryLongInteger 可能有前导0,0的问题,还有就是没有对输入数组处理, 使得他们每次输入时高位的置0,还有就是没考虑到最后相加后的进位,

#include <bits/stdc++.h>
using namespace std;
 
string add(string a, string b) {
    string c;
    int p1 = a.size(), p2 = b.size();
    int p = max(p1, p2), l = 0;
    while (1) {
        int k = (int)a[p1-1]-48+(int)b[p2-1]-48+l;
        char m = (char)48+k%10;
        c += m;
        l = k/10;
        p1 --, p2 --;
        if (p1 == 0 || p2 == 0) break;
    }
    if (p1 == 0 && p2 == 0) {
        if (l!=0) {
            char m = (char)48+l;
            c += m;
        }
    }
    else if (p1 != 0 && p2 == 0) {
        for (int i = p1; i>0; i--) {
            int k = (int)a[i-1]-48+l;
            char m = (char)48+k%10;
            c += m;
            l = k/10;
        }
        if (l!=0) {
            char m = (char)48+l;
            c += m;
        }
    }
    else if (p1 == 0 && p2 != 0) {
        for (int i = p2; i>0; i--) {
            int k = (int)b[i-1]-48+l;
            char m = (char)48+k%10;
            c += m;
            l = k/10;
        }
        if (l!=0) {
            char m = (char)48+l;
            c += m;
        }
    }
    string q;
    for (int i = 0; i<c.size(); i++)    q += c[c.size()-i-1];
    return q;
}
 
 
int main() {
    string s, a;
    a = "", s="0";
    int flag = 0;
    //cout <<add("9345", "900") <<endl;
    //cout << s << endl;
    while (cin >> a) {
        if (a[0] == '0')    break;
        
        s = add(s, a);
       // cout << s <<endl;
    }
    cout <<s <<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值