PAT 1057. Stack

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 10^5). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian
where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print “Invalid” instead.

Sample Input:
17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop
Sample Output:
Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

思路:树状数组加二分查找,用元素索引进行二分查找。

#include<cstdio>
#include<stack>
#include<cstring>
using namespace std;
const int maxn=100005;
char op[15];
int c[maxn];
int lowbit(int x){
    return x&(-x);
}
int sum(int x){
    int res=0;
    while(x>0){
        res+=c[x];
        x-=lowbit(x);
    }
    return res;
}
void add(int x,int d){
    while(x<100005){
        c[x]+=d;
        x+=lowbit(x);
    }
}
int getmid(int size){
    int index=(1+size)/2;
    int left=1,right=100000,mid;
    while(left<right){
        mid=(left+right)/2;//索引值为一半的数是中位数
        if(sum(mid)<index)
            left=mid+1;
        else
            right=mid;
    }
    return left;
}
int main(){
    //freopen("in.txt","r",stdin);
    int T,val;
    memset(c,0,sizeof(c));
    scanf("%d",&T);
    stack<int>s;
    while(T--){
        scanf("%s",op);
        if(op[1]=='u'){
            scanf("%d",&val);
            s.push(val);
            add(val,1);//更新元素索引
        }
        else{
            if(s.empty()){
                puts("Invalid");
            }
            else{
                if(op[1]=='o'){
                    printf("%d\n",s.top());
                    add(s.top(),-1);//删除值,更新元素索引
                    s.pop();
                }
                else if(op[1]=='e'){
                    printf("%d\n",getmid(s.size()));
                }
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值