进制转换简单题

问题

1019 General Palindromic Number (20 分)
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a
i

as ∑
i=0
k

(a
i

b
i
). Here, as usual, 0≤a
i

<b for all i and a
k

is non-zero. Then N is palindromic if and only if a
i

=a
k−i

for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10
9
is the decimal number and 2≤b≤10
9
is the base. The numbers are separated by a space.

Output Specification:
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a
k

a
k−1

… a
0

". Notice that there must be no extra space at the end of output.

Sample Input 1:
27 2
结尾无空行
Sample Output 1:
Yes
1 1 0 1 1
结尾无空行
Sample Input 2:
121 5
结尾无空行
Sample Output 2:
No
4 4 1
结尾无空行

思路

进制转换的两个步骤:
1.将数先转换为十进制数y。

int y = 0,produce = 1;
while(x!=0){
	y = y + (x%10)*produce;
	x = x/10;
	produce = produce*P;
}

2.将十进制数y转换成目标进制数q,q存储在数组中。注意需要从高位往低位输出。

int z[40],num = 0;
do{
	z[num++] = y%Q;
	y = y/Q;
}while(y!=0);

代码

#include<bits/stdc++.h>
using namespace std;

long long N,b;
int z[40],num = 0;
int main(){
    cin>>N>>b;
    do{
        z[num++] = N%b;
        N = N/b;
    }while (N!=0);
    bool flag = true;
    for (int i = 0; i < num / 2; ++i) {
        if(z[i] != z[num-1-i])
            flag = false;
    }
    if(flag == true)
        cout<<"Yes"<<endl;
    else
        cout<<"No"<<endl;
    for (int j = num-1; j >= 0; --j) {
        cout<<z[j];
        if(j!=0)
            cout<<" ";
    }
    if(num==0)
        cout<<"0";
    cout<<endl;
    return 0;
}

总结

注意边界数据的输出,0在任何进制下都为0,且0是回文数字。
注意Yes和No的大小写。

C++中的进制转换通常涉及到整数或字符类型的转换,常见的有从十进制转成其他进制(如二进制、八进制、十六进制),以及从其他进制转回十进制。这里有几个简单的练习供参考: 1. **任务1:十进制转二进制** - 编写函数`intToBinary(int decimal)`,接收一个十进制整数作为输入,返回对应的二进制字符串表示。 ```cpp #include <iostream> #include <string> std::string intToBinary(int decimal); ``` ```cpp std::string intToBinary(int decimal) { std::string binary = ""; while (decimal > 0) { binary = std::to_string(decimal % 2) + binary; decimal /= 2; } return binary; } int main() { int num = 42; std::cout << "Binary representation of " << num << " is " << intToBinary(num) << std::endl; return 0; } ``` 2. **任务2:二进制转十进制** - 编写函数`binaryToInt(const std::string &binaryStr)`,接受一个二进制字符串,计算并返回对应的十进制值。 ```cpp int binaryToInt(const std::string &binaryStr); ``` ```cpp int binaryToInt(const std::string &binaryStr) { int decimal = 0; for (size_t i = 0; i < binaryStr.length(); ++i) { if (binaryStr[i] == '1') { decimal += pow(2, binaryStr.length() - 1 - i); } } return decimal; } ``` 3. **任务3:十六进制转十进制** - 类似地,你可以编写一个`hexToInt(const std::string &hexStr)`函数,处理十六进制到十进制的转换。 对于这些练习,记得处理边界情况和错误输入,例如空字符串、非有效的数字字符等。完成上述基础功能后,可以尝试结合用户输入和错误处理来设计完整的进制转换程序。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值